1. Chevy Truck Forum

    Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online

    Online since 2004, we're the #1 Chevy Truck & SUV user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free

    Registering is Free and Easy! Do it today and we'll see you on the forums soon!

Heating issue...'04 Silverado

Discussion in 'General Chevy & GM Tech Questions' started by Crakums_GT, Feb 20, 2009.

  1. Crakums_GT

    Crakums_GT Epic Member 5+ Years 500 Posts

    Here's the run down. My truck ran into a snow back about 2 weeks ago and now the heater doesn't heat until I rev the engine above approx. 2000rpm. If the truck is idle the heater will blow cool air even when the engine is completely warmed up (half way up temp guage). Once I push the accelerator however the heater works just fine. Also once I have driven the truck and then let it sit again, the heater will continue to blow hot air for a minute or two before going back to blowing cool air. I can't for the life of me, figure out what is causing this. Any help will be much appreciated.

    -Greg
     
  2. jim1958

    jim1958 Member

    Check and see if the upper radiator hose is not collapsing and not allowing the water to flow through the engine
     
  3. Restlessone

    Restlessone Member

    Check coolant level
     
  4. Crakums_GT

    Crakums_GT Epic Member 5+ Years 500 Posts

    Thank you. I'll let you know what I find.
     
  5. Crakums_GT

    Crakums_GT Epic Member 5+ Years 500 Posts

    Thanks you all. I ended up finding a coolant leak. It is now fixed and the heat is back. Thanks again.
     

Share This Page