Hello from Columbus Ohio

Discussion in 'Member Introductions' started by TheShamrock7, Oct 11, 2007.

  1. TheShamrock7

    TheShamrock7 New Member

    Hello everyone! I have a 2005 Chevy Trailblazer Ext 4x4. I was loving it until I started having problems with my heat/air blowing I replaced the blower motor resistor and noticed the harness was melted in 2 spots, can any one point me in the right direction or help. I have been a die hard chevy fan all my life and had 1989 S-10 , 95 S-10 and never had no problems and now this. :grrrrrr:
     
  2. Cableguy

    Cableguy Epic Member 5+ Years ROTM Winner 1000 Posts

    :sign0016:from Canada


    Don't sweet the small stuff I spent $1600 replacing 1 O2 sensor (Long story-Retarded dealership) on my 03 TB. If thats all thats gone wrong your not doing to bad.
     
  3. TahoeFever

    TahoeFever Epic Member 5+ Years 500 Posts

    cableguy you spend 1600 on a 127 usd part?? did you at least get a refund of some sort ? and i thought crappy tire was bad :lol: oh and shamrock7 Welcome to the one of most craziest forums here ! LOL
     
  4. MD4x4 Fireman

    MD4x4 Fireman Epic Member 5+ Years 1000 Posts

    :sign0016: to the party. check out the tech sections to see if anyone has had this problem before.
     
  5. Davandy

    Davandy Moderator 5+ Years ROTM Winner 1000 Posts

    :sign0016: to the site.
     
  6. RockHead

    RockHead Epic Member 5+ Years 500 Posts ROTM Winner

    :sign0016: to the site
    :great:
     
  7. ChevyFan

    ChevyFan The Sheriff Staff Member 5+ Years 5000 Posts

    Welcome! :party:

    Post a topic about this in one of the forums, someone will be sure to try to help you out.
     

Share This Page

Newest Gallery Photos