1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

hello from st. louis

Discussion in 'Member Introductions' started by maximum_overdrive, Nov 2, 2008.

  1. maximum_overdrive

    maximum_overdrive New Member

    hello i just got a 95 suburban and i though id introduce my slef . im joe and this is my 2wd suburban with the 350 . this is the only pic i got right now (from the craigslist ad). its lowered some but im going lower in the rear. ive always wanted one and now ive got it.:happy:

    but i do have a question. when on part throttle it bogs down but if i floor it it picks up. it also searches for idle at stops.(300-400 rpm) i was told it needs a o2 sensor but would that give me my problem?

    i will get good pics on monday. (the wheels ARE the same color)

    [​IMG]
  2. tlperry68

    tlperry68 Epic Member 5+ Years 1000 Posts

    Welcome to the site. Changing the O2 sensor is a good start. 300 - 400 RPM seems a bit low to me but I'm not sure. Normally V8 motors (while in park or netural) idle a little above 600. How's the Landing holding up in ST. Louis?
  3. maximum_overdrive

    maximum_overdrive New Member

    i meant it searches 300-400rpm . it idles about 600 then jumps to 1000
    Last edited: Nov 2, 2008
  4. MWright936

    MWright936 Epic Member 5+ Years 1000 Posts

    Welcome to the site and congrats on the Suburban!
  5. Springthing

    Springthing Epic Member 5+ Years 1000 Posts

    Welcome to the GMTC. I hope you can get your problems fixed and get to loving the new ride. I'm sorry I can't be of any help with your problem.
  6. dwill3015

    dwill3015 Epic Member 5+ Years ROTM Winner 1000 Posts

    Welcome to the site!
  7. retired2001

    retired2001 Epic Member 5+ Years 5000 Posts

    Welcome to the site! Another Suburban joining the site! You might do well by having someone check for trouble codes. A lot of the "parts stores" will check them for you. Good luck!
  8. bry2500

    bry2500 Epic Member 5+ Years 1000 Posts

    Welcome to the site. That problem sounds iritating. I would definitely get the codes checked. But I'm betting on one of the 02 sensors too.
  9. 04sierracrewcab

    04sierracrewcab Epic Member 5+ Years 1000 Posts

    welocme! congrats on the new burb!
    hope you can get your problems resolved with our asstiance!
    :great:

    :sign0016:
  10. maximum_overdrive

    maximum_overdrive New Member

    heres the pics, o and the o2 sensor was bad , it looked like someone hit it with a hammer
    its not bad for $2200

    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]

Share This Page