1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

help! 92 issues

Discussion in 'Chevy C/K Truck Forum' started by cooter71, Dec 16, 2012.

  1. cooter71

    cooter71 Member

    okay so my original 305 in my 92 took a dump and i bought a freshly rebuilt motor from a friend of mine thats a 350 bored .030 over with a towing/rv cam in it, it is a throttle body motor. the motors solid, and strong but i had to use my throttle body off of my 305 for it. so now when i'm driving (this is only sometimes) around 2000 Rpms the motor will spit and sputter and carry on, then right around 3000 rpms it runs fine. also, sometimes when the truck is in gear at idle it will want to die (its an automatic obviously). I have replaced the EGR valve. My questions are... first, could my IAC valve be causing this wanting to stall? also could the throttle position sensor be causing this sputtering in the top end? Do you think my throttle body should be thoroughly cleaned and have new injectors installed? and finally, my timing is set at 0 degrees avdvance, do you think with the towing cam in it i should advance it two degrees? please help
  2. tbplus10

    tbplus10 Epic Member Staff Member 5+ Years 5000 Posts Platinum Contributor

    The first place to start is with the cam manufacturer, you need to find out their reccomendation for timing settings.
    If the throttle body hasnt been cleaned in a while then theres nothing to loose by cleaning it.
    Injectors at the very least should be cleaned and pressure tested.
    And while your under the hood clean the IAC.

Share This Page