1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

Help! electrical issue...I think?

Discussion in 'General Chevy & GM Tech Questions' started by chopper1, Dec 12, 2011.

  1. chopper1

    chopper1 New Member

    Hi I've had my new (1999) silverado for 1 week and 2day she wouldn't start! Truck is like new inside and out and runs like it's new...60K mi. Sometimes the security light stays on while driving and the manual says that could be a problem with the passlock system? The truck always starts the instant you turn the key but 2day while out running errands she wouldn't start? She tried to start but it seemed that something electrical was shutting it down before it could keep running? I tried several times and same result. I waited about 20 min and tried again and it started right up? Any help will be greatly appreciated!
  2. dipstick

    dipstick New Member

    Security will cut fuel pump off ..can you hear pump run when a no crank? Do you know the procedure to clear security ?
    Should be in your service manual ..
    Oh if you hear pump.. will not be security need to check fuel relay, maybe getting hot /intermittent and pressure.
  3. chopper1

    chopper1 New Member

    Hey thanks man ..from what I have found out so far the passlock system is bad or going bad...mechanic says they all go bad..junk system ...and it costs about 500 to 600 to replace it ...and he is cheaper than a dealership. I knew I shoulda bought another toyota!
  4. dipstick

    dipstick New Member

    Before buying anything .. can you hear fuel pump come on when you turn key to on position.? When you have a no start situation.
    Need to check for spark also when a no start.
  5. sstoner911

    sstoner911 New Member 1000 Posts

    Is this the pass lock II system? Guys disable them all the time and get aftermarket alarms. Do you have tilt wheel....sometimes if it only seems to be problem when the wheel is tilted at a certain posistion the harness is bad only.

    If you google " disable passlock security system" you will find what your looking for.

    There is this option too...


    http://www.amazon.com/Fortin-PASSLOCK-SL2-Passlock-Learning-Starter/dp/B0011TQNH8
    Last edited: Dec 16, 2011
  6. chopper1

    chopper1 New Member

    thanks again for your help! I've only had a no start situation 1 time so far... been using my car this week to prevent getting stranded. I was upset when it happened and didn't pay attention to fuel pump...next time I will listen for fuel pump. Found out my friend's malibu does the same thing...and he resets it by leaving the key in the on position for 10 mins... turn key off and then it starts?

    ---------- Post added at 11:45 AM ---------- Previous post was at 11:38 AM ----------

    thank you! I had no idea there was a whole industry dedicated to fixing this problem! I do not know yet if it is a passlock II or I? btw..Your truck is Sweet!!
  7. sstoner911

    sstoner911 New Member 1000 Posts

    Thanks Chopper!

    I would say the issue seems to be with the passlock....I would just bypass it and get an aftermarket alarm.

Share This Page