1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

Help Please! - Speedometer Not Working

Discussion in 'Chevy Silverado Forum (GMC Sierra)' started by killem, Jun 14, 2006.

  1. killem

    killem New Member

    Okay, my problem is simple. My speedomer isn't working.

    Basically, every since the other night it has been pegged on 100, and will not move. I beleive that it got shorted out while I was messing with some wires going through the firewall.

    I've tried looking for a fuse for the speedometer to see if it was blown, but could never find one that was for the speedometer.

    Maybe something came lose? Not sure.

    By the way, this is a 1999 Chevy Silverado Z71, new body style. All other guages work on the dash... except for the speedometer which is pegged at 100.

    Like I said, I'm figuring that I shorted it out the other day when I was messing with the cables -- though I couldn't find a fuse for the speedometer.

    Any wiring diagrams, or advice on how to fix this would be much appreciated.

    Please advise...
  2. mmeado

    mmeado New Member

    I had a similar problem in my 2000 S-10, which I no longer have, but it ended up being the fuse for the radio...I know that sounds weird but that fuse was blown, and after replacing it the speedo worked fine. Hope this helps.

Share This Page