Hi there from Vancouver, WA

Discussion in 'Member Introductions' started by IronMan, Jan 10, 2011.

  1. IronMan

    IronMan New Member

    Hi guys! Just found this forum over the weekend while searching for some help, so I figured I should join.

    I have a 1998 GMC 2500 3/4 w/ 7.4l (will get pics up soon).

    Last week I got a check engine light and borrowed a code reader to see whats up. Ended up with 2 codes: P0141 - O2 sensor heater cicuit malfunction bank 1 sensor 2; P1415 manufacturer control auxillary emission control. After resetting the faults, only he P1415 keeps coming back.

    It's for the air pump, or smog pump as some call it. Everything appears to be working normally, it comes on when the engine is cold and kicks out after a short while. The diverter valve also looks good according to the Haynes manual test procedure.

    Somehow, I don't think that the pump is the reason for the faults, maybe a bad O2 sensor - emmisions related problems are hard to diagnose from my past experience.

    Anyways, if somebody has some past experience with this or any clues, I would appreciate it since I need to pass DEQ by the end of the month.

    Thanks alot.
     
  2. murdog94

    murdog94 Epic Member 5+ Years 5000 Posts

    Welcome aboard. You will get more responses if you post your questions in the appropriate subforum since that is where most hang out. Good luck finding the fix!
     
  3. TexasEdition

    TexasEdition Rockstar 3 Years 500 Posts

    Greetings........
     
  4. stephan

    stephan Rockstar 4 Years 5000 Posts

    Welcome to the club Iron Man
     
  5. Bigbomber

    Bigbomber Rockstar 4 Years 5000 Posts

    Welcome to the club!
     
  6. retired2001

    retired2001 Epic Member 5+ Years 5000 Posts

    Welcome to the G M T C !
     
  7. canislupis69

    canislupis69 Epic Member 5+ Years ROTM Winner 5000 Posts

    Welcome to the club!
     

Share This Page

Newest Gallery Photos