GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER

high idle only when moving

Discussion in 'General Chevy & GM Tech Questions' started by gostr, Nov 29, 2009.

  1. gostr

    gostr New Member

    Joined:
    Apr 2, 2009
    Messages:
    10
    Likes Received:
    0
    Hello,

    I have a 99 suburban with a 5.7 vortex with an [COLOR=blue !important][COLOR=blue !important]auto[/COLOR][/COLOR] tranny. When I am driving and let off the gas the rpms stay at around 1200-1500 even if I am coasting in N. When I let off the gas to slow down it wont. When I come to a complete stop they will drop. If I am stopped and in park and rev the [COLOR=blue !important][COLOR=blue !important]engine[/COLOR][/COLOR] it comes down to a normal idle. This just started a few days ago. any idea what it could be??


    Thanks
    #1
  2. Jimmiee

    Jimmiee New Member

    Joined:
    Feb 26, 2009
    Messages:
    2,285
    Likes Received:
    12
    The first thing that comes to mind is a dirty throttle body. I would clean the throttle body and mass airflow sensor while you're at it. Have you checked for any trouble codes?
    #2
  3. gostr

    gostr New Member

    Joined:
    Apr 2, 2009
    Messages:
    10
    Likes Received:
    0
    Checked codes nothing came up. I will try to clean maf today. I just don't get why it only does it when the truck is moving.
    #3

Share This Page