Horrible MPG Advice!

Discussion in 'Performance & Fuel' started by Silverado1500, Jan 4, 2010.

  1. Silverado1500

    Silverado1500 New Member 100 Posts

    i have a 2000 4x4 1500 silverado lifted 3 inches with custom exhaust and thats pretty much it. im pretty positive it has a 26gal tank and i can only get about 200 miles on a tank. so thats about 7-8mpg!this is terriblee! can anyone help me out on this?
    i do normal driving city and highway
  2. J_chevyman

    J_chevyman New Member

    Re

    Have you changed spark plugs and wire? fuel filter? I had the same problem. ...getting crappy mileage but I changed wire and plugs, that worked for me...
  3. Silverado1500

    Silverado1500 New Member 100 Posts

    yes i changed them to the irridium plugs, but do you have to change the wires also?
  4. ahm1127

    ahm1127 New Member 100 Posts

    I would! Its 10 years old, are you the original owner? How many miles? How does the air filter look? Have you changed fuel filter? Do the maintenance the GM recommends at the mileage your truck has. Good luck
  5. Silverado1500

    Silverado1500 New Member 100 Posts

    no i am not the original owner. i bought it about a month ago
    it has 102,000 miles on it

    so if i do all of this, how much mpg do you think i would get? because i have 7mpg as of now and it is killing me
  6. duck44

    duck44 New Member

    What size tires do you have this would affect the calculations also.
  7. tbplus10

    tbplus10 Super Moderator Staff Member Platinum Contributor 1000 Posts 100 Posts

    It has a lift so what size tires are on it and whats the gear ratio? This could be part of your problem.
    A full tune-up cant hurt.
  8. Silverado1500

    Silverado1500 New Member 100 Posts

    well on the tires it says LT 305/70R16
  9. Silverado1500

    Silverado1500 New Member 100 Posts

    im not sure what gear ratio it has. and i just got into trucks and i dont know how to check or change it
    can u give me some advice on that too?
  10. JennaBear

    JennaBear New Member 100 Posts

    Have you replaced the fuel filter and fuel pump?

Share This Page