horrible sputter/ miss

Discussion in 'General Chevy & GM Tech Questions' started by fab_101, Jul 16, 2009.

  1. fab_101

    fab_101 New Member

    my '94 chev 454 with tbi is sputtering horribly and i cant figure out what it is. i've checked the fuel pressure, the injectors, plugs, wires, etc. . . any other suggestions its not constant either its been doing it for a long time. ive rebuilt the heads since it started doing it. also i have done compresssion check and it reads great.
     
    Last edited: Jul 16, 2009
  2. redneckarmyMP

    redneckarmyMP Epic Member 5+ Years 500 Posts

    have you replaced any of the plugs, wires, etc?
     
  3. fab_101

    fab_101 New Member

    i have replaced it all. with premium.
     
  4. Jimmiee

    Jimmiee Epic Member 5+ Years 1000 Posts

    Did you change the injectors? Have you thought about having the engine checked with an oscilloscope. This will show where the problem is located.
     
  5. fab_101

    fab_101 New Member

    havent changed the injectors, but ive had them tested. and i dont know what an oscilloscope is
     
  6. Jimmiee

    Jimmiee Epic Member 5+ Years 1000 Posts

    The scope shows the secondary spark voltage on a graph. You can see which cylinders are misfiring.
     
  7. fab_101

    fab_101 New Member

    ill have to try that that tonight. ill let you know the results
     
  8. bry2500

    bry2500 Epic Member 5+ Years 1000 Posts

    does it sputter at idle, under throttle, or both. Have you made any mods before it happened.
     
  9. fab_101

    fab_101 New Member

    it does it worse under throttle and lightly at idle and i havent done any mods to it. i wish though
     

Share This Page

Newest Gallery Photos