Newest Gallery Photos

  1. Chevy Truck Forum

    Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online

    Online since 2004, we're the #1 Chevy Truck & SUV user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free

    Registering is Free and Easy! Do it today and we'll see you on the forums soon!

  1. Gino3131

    Gino3131 New Member

    my daily driver is a 98 two door Tahoe with a 5.7 vortec. My problem is when the engine starts to warm up and when it is warm, it starts to misfire when trying to hold a constant speed by foot feed or by cruise control. Recently have put new plugs and wires with dist cap also, but still have the misfire. Does any one have any idea as to where my problem may be?
     
  2. a.graham52

    a.graham52 Rockstar 100 Posts

    did you replace the rotor button with the cap as well?
     
  3. Gino3131

    Gino3131 New Member

    That also was changed, I forgot to mention that in my previous post.
     
  4. TRPLXL2

    TRPLXL2 Epic Member 5+ Years 1000 Posts Platinum Contributor

    Have you checked the coil?? The design of the 5.7 puts the coil succeptible to extreme heat, and causes premature failure. Normally when you replace them, they give you a grease that helps keep the heat away from the coil.
     
  5. Pikey

    Pikey Moderator Staff Member 3 Years ROTM Winner 1000 Posts

    Could it possibly be a stuck EGR valve. If it idles fine but, will miss under a load, you might want to take a look at the egr.
     

Share This Page