1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

I got it !!!

Discussion in 'General Chevy & GM Tech Questions' started by brickborn, Mar 20, 2011.

  1. brickborn

    brickborn New Member

    Well guys I finally got it up and going again. I replaced the distributor , which got me spark back and fired my injectors . Well it would try to start but not stay running . So I took it to the dealer . They wanted to charge me 647.00 to install new injectors cause one wasn't firing , the injector kit was only about 230.00 , i said no and towed it back home .later that day I took the injectors out of my 89 sub installed them in my 90 which took literally 30 mins . Jumped in turned the key and bang flowmasters growling again . I yelled and screamed f yeah up and down my road like a cyco . So glad to be rolling again .
    Thanks for all the help and suggestions ! I really do appreciate it I owe you guys some beers!
    The last thing I can say is f the gmc dealerships they are fn ripoffs . It really gets me how they try to rip people off. Signing off Brickborn
  2. stephan

    stephan Rockstar 3 Years 5000 Posts

    Do you have the link to your old thread on this so we can review the original symptoms ?

Share This Page