I think I may have found that blasted ATF leak

Discussion in 'GM Powertrain' started by Crawdaddy, Jul 13, 2008.

  1. Crawdaddy

    Crawdaddy ↑↑↑ Has no life Staff Member 5+ Years 1000 Posts Platinum Contributor

    Well, this morning, in an attempt to find and eliminate my ATF fluid leak, I decided to get under the truck with a torque wrench, a can of carb cleaner, and a whole ton of shop rags. So, I torqued all the transmission pan bolts to 10 foot-pounds as per the documentation I have. A few of the bolts were loose, so that may have been the culprit, but I don't think so... Then I went to town with the can of carb cleaner hitting the outside of the transmission case, transmission pan, and the floor pan around the transmission. I was steadily cleaning and made sure to hit the tailshaft and front driveshaft yoke. Got everything relativeley clean, so I started on the floorpan. While I'm working on the floorpan, I'm noticing a very steady drip out of the corner of my eye. Beads of CLEAN ATF (I'm 98% sure it wasn't runoff or drips from the floorpan) were forming and falling to the ground. So, I made haste to get to that part of the floorpan. Sure enough, there's a thicker than the average line of crud right around the U-joint. I cleaned that are off thoughroughly, and all the while, every 10 seconds or so, another bead of ATF forms and drips to the ground. I inspected the rear seal on the tailshaft as best I could, and didn't see anything suspect there. I thought the yoke on the front of the tailshaft was a solid piece, and therefore couldn't leak through. Judging from the location where the drips are forming and falling from, I don't think its running along the outside of the yoke to the u-joint ear. Any clue where the ATF is coming from and how to stop it? Dropping the driveshaft isn't an issue if it'll help me fix the problem. Thanks all as usual...
     
  2. tbplus10

    tbplus10 Epic Member Staff Member 5+ Years 5000 Posts Platinum Contributor

    From your description the rear seal is the culprit. It isnt hard to tear the seal or tweak the tension spring on the inside of the seal enough to cause a leak. At that area the only other possibility would be a crack on top the case that you cant see.
    My moneys on the seal, probably on the top of it.
     
  3. freddie

    freddie Rockstar 100 Posts

    Well I don't really know what you mean by ATF fluid. So hopefully I'm not misunderstanding you. I just had some recent problems. The dealership replaced my yoke because it was leaking and there is a type of freeze plug on top of the rear trans. that they just pulled out and put some silicone on and put back in because it was leaking. Also, I had a seal and bushing replaced. That goes in behind the yoke, which was difficult to replace myself because you have to have a seal puller and something to pull the bushing out. If any of this sounds like it may be your problem I could possibly give you more info about it.

    Hope this helps
     
  4. Crawdaddy

    Crawdaddy ↑↑↑ Has no life Staff Member 5+ Years 1000 Posts Platinum Contributor

    Tim, you're talking about the rear seal that's on the tailshaft of the transmission, right? I guess I'll have to snag a new seal and swap it out. I think I can pull the seal without pulling the tailshaft off and get it back on. I'll also make sure to install it with a seal installer. When my uncle and I originally installed the transmission, we had to transfer the tailshaft section of the case from the old transmission to the new one. Don't ask me why, probably because of all the different vehicles the 700R4 can bolt into. However, we were provided with a new tailshaft seal and we installed it with a hammer and board, not the best tools for the job... We'll see what happens. Oh, and as an update, I put a pan under the u-joint at about 10:35am today, and it's currently 11:15 am. In this amount of time, the pan has collected probably a capfull of ATF already, so it's leaking at a pretty quick rate. :gasp:

    Freddie: ATF is automatic transmission fluid, sorry about the abreviation...
     
  5. tbplus10

    tbplus10 Epic Member Staff Member 5+ Years 5000 Posts Platinum Contributor

    Yep, the seals are usually cheap around $10 and arent hard to replace, they just take a little time to pull everything apart and put it back together.
    Getting the trans without a tailshaft is common. Like you pointed out theres so many combinations this trans fits on.
    The auto parts store may have a seal tool to reinsert the new seal. If your using Auto Zone or Pep Boys they may have a loaner or rental tool you can use. It's very easy to get the seal in a little cocked off center and tweak things a little when you run the driveshaft yoke in.
     
  6. Crawdaddy

    Crawdaddy ↑↑↑ Has no life Staff Member 5+ Years 1000 Posts Platinum Contributor

    I just got from under the truck, and I can now confirm that the issue is NOT the seal on the tailshaft. I inspected the rear seal, the exposed part of the slipyoke that slides into the tailshaft of the transmission, and the top of the transmission case. I could not find traces of ATF anywhere. I got under there and inspected on the inside are of the u-joint area betweek the ears of the yoke(I'm guessing that's the right term...) It seems that there is a pinhole sized hole in the center, and that's where the ATF is coming from. I got under there with the camera to try to illustrate where it's coming from. I hope it's clear...

    [​IMG]

    [​IMG]

    Neither of the pictures really were able to see the hole, but you can clearly see the drop of ATF that was fixing to fall to the ground. The first shot was taken looking nearly straight up. The second one was taken from the passenger side of the truck. Now, I have NO clue what seal or whatever existing in that ares, but it's leaking. Any idea what part that is and how to fix it?
     
  7. Crawdaddy

    Crawdaddy ↑↑↑ Has no life Staff Member 5+ Years 1000 Posts Platinum Contributor

    So far, I have found this thread that seems to relate to what I'm experiencing. http://www.hotrodders.com/forum/4l60e-tailshaft-sleeve-57139.html

    Now, can someone convert this into n00bese so that I can figure out what needs to be done? It looks like I either need to obtain some sort of special grease to grease the splines of the tailshaft and yoke, or I need to yank the talshaft housing off and replace some sleeve that's in there.... Any wisdom to be had? Thanks as always...

    EDIT:

    Grasping for any clue or ideas, I also found this page http://www.442.com/oldsfaq/oftswp.htm . Way down the page it says this...

    While this does not adress a 700R4 transmission or a truck, it seems like it might shine some light on the situation. The driveshaft I'm using is original to the truck, but the transmission is a rebuilt I bought from a rebuilding company. (see my old transmission thread to get the gritty deatils about that if neccesary) I wonder if the actual tailshaft shaft is different from cars to trucks? I am fairly sure that the actual output shaft in the tailshaft is a different length from 2wd to 4x4. If I have a short shaft and I'm supposed to have a long shaft or something, that may do it from what I'm gathering... I'm clueless at this point other than the blasted thing is leaking at probably close to 1/4 of a quart a DAY when it's sitting during the week.


    I just looked at the pictures I posted to. Is it just me, or does that yoke seem to not be very far into the transmission tailshaft. That doesn't make any sense though, because the driveshaft, rearend, and tailshaft are all original to the truck, so all the dimensions should be in the same relation to each other. Those pictures were taken on level ground and no jacks or jackstand picking the truck up any.
     
    Last edited: Jul 13, 2008
  8. Crawdaddy

    Crawdaddy ↑↑↑ Has no life Staff Member 5+ Years 1000 Posts Platinum Contributor

    I think I found a "dumb english" walthrough on fixing my issue. There's a seal in a retainer thing on the output shaft that's got something wrong with it. Whether it's non-existant, backwards, or just broken/worn out, I'm not sure, but I'm now 98% sure this is the issue and that I need to follow this webpage to fix it.
    http://www.73-87.com/7387garage/drivetrain/yokeleak.htm

    However, this will have to wait until next weekend at least so I can get my support crew to assist me in fixin' it...
     
  9. Crawdaddy

    Crawdaddy ↑↑↑ Has no life Staff Member 5+ Years 1000 Posts Platinum Contributor

    I ordered the yoke seal and bought a replacement tailshaft housing seal, just in case. I still need/want to order some new u-joint straps and bolts for the pinion to make sure they don't break off in the pinion.
     
  10. tbplus10

    tbplus10 Epic Member Staff Member 5+ Years 5000 Posts Platinum Contributor

    You probably know this already but when you get ready to assemble the D shaft put a little Trans fluid on the seals and the outside of the splines, this'll help it slide in a little better and stop from rolloing the "O" rings or tearing the seals.
     

Share This Page

Newest Gallery Photos