I think my Surburban has CANCER!

Discussion in 'GM Electrical Tech' started by Pickels, Sep 1, 2007.

  1. Pickels

    Pickels New Member

    2004 Surburban -

    First the Speedometer stopped working

    Next the Tachometer quit

    Then the Temperature gauge quit

    Then the Voltage gauge quit.

    This all happened over the space of three months!

    I checked the fuses and they seem ok.

    Anyone got any idea what could cause this?
     
  2. 84fiero123

    84fiero123 Epic Member 5+ Years 1000 Posts Platinum Contributor

    With the little info you give it is hard to give you an answer. If I were you first I would check on recalls and tech bulletins here.

    http://www-odi.nhtsa.dot.gov/cars/problems/recalls/recallsearch.cfm

    Sounds like a problem in the dash cluster, wiring maybe? It could be something that has a tech buleten on so like I said check that first.

    One thing I would like to know is the dash digital or analog, you don’t mention that?
     
  3. Pickels

    Pickels New Member

    The dash has gauges with needle arms for indicators so I assume it is analog. But with todays electronics - who knows :)
     
    Last edited: Sep 2, 2007
  4. unplugged

    unplugged Epic Member 5+ Years 1000 Posts

    Defective stepper motors?

    Apparently a common problem. $200 for a reconditioned cluster plus programming.
    From: Speedometer Sales
    [​IMG]
     
  5. 2wheelin

    2wheelin New Member

    my instrument panel

    2004 Suburban LT
    Got in the truck this morning and started driving down the street and noticed I had already hit 60 just as I pulled out of my drive way. I thought, wow! I had better slow down. Well, looks like my instruments are on there way out.
    Funny, I just received a letter in the mail this week from GM extending the warranty on my instrument panel. Say's if you spent any money repairing this part you can get a full refund. I am taking mine in today to have it fixed.
     
  6. Aeropagus

    Aeropagus Rockstar Platinum Contributor 100 Posts

    Can you scan that and post it? I'd like to read that if at all possible.
     
  7. JayMack75

    JayMack75 Former Member

    Well that just answered a question I was going to ask. My speedometer sticks or shows incorrect speed constantly. I thought it was just me.
     
  8. 2wheelin

    2wheelin New Member

    speedometer

    let me try and scan..
     
  9. gmcjimmy88

    gmcjimmy88 New Member

    Sounds like a ground problem to me? Keep us posted on what happens.
     

Share This Page

Newest Gallery Photos