GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER

Installing Aftermarket Radio

Discussion in 'Chevy Suburban Forum (GMC Yukon XL)' started by suburbanboy, Jun 1, 2009.

  1. suburbanboy

    suburbanboy New Member

    Joined:
    Jun 1, 2009
    Messages:
    4
    Likes Received:
    0
    I am trying to install an after market radio and system in my 1997 suburban. I have everything installed properly (amps, cross overs ,et)c and when i plugged the new radio in only my drivers side front speaker goes on. Is there a factory amp or something in the truck I am missing? Wiring harness is all plugged in correctly. Speakers work fine with factory radio unit plugged in. Any ideas would be appreciated... Thanks...
    #1
  2. unplugged

    unplugged New Member

    Joined:
    Sep 9, 2006
    Messages:
    2,554
    Likes Received:
    12
    #2
  3. SuburbanSS

    SuburbanSS New Member

    Joined:
    May 31, 2009
    Messages:
    48
    Likes Received:
    0
    Did you buy a harness to plug into your factory harness then into the new radio?

    Did you splice the factory wires?

    Do you have an external aftermarket amplifier?

    Are you replacing the stock speakers?

    Need a little bit more info and I'll be able to help you a bit better.
    #3
  4. suburbanboy

    suburbanboy New Member

    Joined:
    Jun 1, 2009
    Messages:
    4
    Likes Received:
    0
    Thanks everyone but I figured it out. It was the factory amp under the dash that was causing my problems. Took it out and all is ok...
    #4
  5. Bredin

    Bredin New Member

    Joined:
    Feb 11, 2009
    Messages:
    75
    Likes Received:
    0
    Hey,

    Where did you find the amp under the dash?

    I'm having the problem that I am only getting sound thru my front speakers, no sound thru the passenger door speakers and only a high tune sound from the speakers in the back in the roof...
    #5
  6. YotaLuver

    YotaLuver Former Member

    Joined:
    Nov 9, 2009
    Messages:
    12
    Likes Received:
    0
    Amp location

    My Delco factory installed amp was under the blower, passenger side, in a blck box. I always wondered what was inside there and found out when the amp died.
    #6

Share This Page