1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

instrument panel light problem

Discussion in 'General Chevy & GM Tech Questions' started by 89k2500, Jan 25, 2009.

  1. 89k2500

    89k2500 New Member

    i have a 89 k2500 chevy and when i turn on the headlights or the parking lights the instrument panel lights go out but the turn signal indicator lights stay on, the high beam indicator light goes on when the low beams are on and go out when the high beams are on, the warning lights work just fine.....once in a while they will come back on and then go right out a couple minutes later or when you go to start the truck back up......btw sometimes when i hit the bottom left side of the instrument cluster they go on.....i think it might be a short but i cannt find a place in the dash to check the wiring to the cluster.......if anyone has an idea of how to fix this or knows whats going on it would be appreciated......thanks
  2. 04sierracrewcab

    04sierracrewcab New Member 1000 Posts

    How are the fuses?? Any blown ??
  3. mrfixdit

    mrfixdit New Member

    instrument panel

    Do you have a little aluminum block in your fuse panel? If so these are cube relays, one of them may be bad, see if tapping on it with a screwdriver handle makes the lights come on.
  4. 89k2500

    89k2500 New Member

    no none of the fuses are blown and no there is not a relay fiy either the cluster or headlights
  5. mrfixdit

    mrfixdit New Member

    inst. panel lights

    The relay will be designated as "accessory"
  6. SilveradoBrett

    SilveradoBrett New Member

    This situation reminds me of my truck. My dash does all kinds of weird things like that. First of all the oil pressure guage bounces around constantly and never stays in one place for more than a few seconds. The truck draws too much power and when it does the radio just shuts off and turns on repeatedly so I only hear a few words of each song. The volt guage will drop all the way down to nine and then suddenly bounce back up to 13. Its really weird and I have not been able to figure it out! I have a 96 K1500 Silverado and I am so frustrated by it because the problem has left me stranded in the past but continues to persist. (Look at my Silverado Blues Post) I actually took it into the shop today to see if a "certified" electrical monkey could get it fixed. My thoughts are that the cluster motherboard is shot and needs to be replaced. I should know later today if they could figure it out and get it fixed. When I do I will post the solution on here and maybe it will help you out. Good luck!
  7. 89k2500

    89k2500 New Member

    i think that i found the problem.....the contact on the wiring harness was not connecting good that oes to the cluster lights....i just bent the metal holder in the contact for the pin and they came back on.......thanks for the help
  8. SilveradoBrett

    SilveradoBrett New Member

    Well that was a nice and easy fix! Good work! I finally got my truck working again and it was just missing grounds. Battery to body, body to frame, body to motor. That was what was causing all of my problems. Glad you figured it out!

Share This Page