1. Chevy Truck Forum

    Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online

    Online since 2004, we're the #1 Chevy Truck & SUV user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free

    Registering is Free and Easy! Do it today and we'll see you on the forums soon!

interesting condition

Discussion in 'Chevy Suburban Forum (GMC Yukon XL)' started by scgamer_99, Nov 15, 2009.

  1. scgamer_99

    scgamer_99 Rockstar

    ok so i just noticed that my burban will be running fine blowing hot air out of the heater and everything, then all the sudden it starts cooling down, so i glanced at the temp of the engine and it has shot up to 240ish it usually runs 190 area, so i keep looking at it then all the sudden it drops like a brick and the heater turns hot, what the hell? i was kinda thinking the thermostat what do you guys think?
     
  2. reaper

    reaper New Member

    Thermostat is the area I would be looking. I have had the same prob with some of my older units. I have also seen this on my vette when the water pump started heading south.
     
  3. boduke5051

    boduke5051 Member

    I'd think either a sticking thermostat, or a clog in the cooling system right around the heater core area. I'd suggest a new thermostat, and a cooling system flush. If you don't want to pay to have the flush done, I think I only paid about 20 or 30 bucks for a flush kit (guessing high I think) at the local parts store, & it just hooks up to your household garden hose spiget. You'd be AMAZED, or Grossed out at the things that a cooling system flush will spew out onto your driveway. I did an S-10 Blazer one time that looked like a cat coughing up a hairball big enough to make a complete wig for a long haired schnauser. I've got to admit it was one of the only times that working on a car actually turned my stomach. lmao.
     
  4. scgamer_99

    scgamer_99 Rockstar

    sorry i didnt follow up on this lol, anyways so i was thinking since i was going to replace the thermo anyways just to see if that was the reason i would change my belt, looked old, and right when i took the pressure off i sprang a leak from my water pump, took it off and wouldn't you know the only thing holding it tight was the belt, one bolt was totally rusted through and when i went to buy another one the split the old one open just to see and the propeller blade was half gone lol so i found my problem
     

Share This Page