1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

Intm. Windshield Wipers. [Expired Topic]

Discussion in 'Chevy Suburban Forum (GMC Yukon XL)' started by udderchaos, Sep 2, 2006.

Thread Status:
Not open for further replies.
  1. udderchaos

    udderchaos Rockstar

    My 98 has a problem with the delayed /intermitent(sp) wipers. After the wipers have been on for a while (20 + minutes), the motor seems to get "lost". It stops the wipers all over the windshield, except at the bottom. They were even stopping all the way up...... After I shut the wipers off, and wait a couple of minutes, they do ok, for a while. If I leave them on slow speed, no delay, they're fine... Is the wiper motor going bad..?? Some electrical glitch...??? How expensive is it to fix.???
  2. nemopoppins

    nemopoppins Rockstar

    RE: Intm. Windshield Wipers.

    I don't know if this is the same problem but I had trouble with my 99 Suburban intermittant wipers. They would sometimes not be intermittant, sometimes stop, but most of the time they wouldn't turn off until I turned the car off. That was a real pain because it hardly ever just rains here. So, when there was some rain, I would be reluctant to put on my wipers for fear that when it dried in a few minutes I wouldn't be able to turn them off and they would keep scraping until I pulled over.

    Anyway, there's some sort of control box mounted just at the back of the engine compartment on the firewall. I got a replacement part from the dealer (not expensive, I believe it was around $30). He told me they sell lots of them. I replaced the old part and that did it. I'm sorry this is not very technical, but maybe someone more knowledgeable can add to this.
  3. ChevyFan

    ChevyFan Administrator Staff Member 5+ Years 5000 Posts

    RE: Intm. Windshield Wipers.

    I have only heard of this being a known issue on certain late 90's Ford, not GMC products. Do you have one of the new "rain sense" sensor systems?
  4. udderchaos

    udderchaos Rockstar

    I don't have the rain sensor, that I know of. I've never had a Chevy do this either. It doesn't really cause any harm, but man...it annoys the dickens out of me. They shut off when I turn them off. They even have the same speed interval that they are set on. They just stop at various stages of the wipe cycle.... It has a wiper motor from NAPA.....could have been a problem for the previous owner.??? Is the motor what tells tells the wipers how far to go, or is there something else that tells the motor how far to go.?? I hope this makes sense, because, I don't know how else to explain it.......
  5. ChevyFan

    ChevyFan Administrator Staff Member 5+ Years 5000 Posts

    Well, it sounds like a short somewhere in the control unit, not the motor. If it were the motor, it would eventually burt itself out I would think, or it would NOT run when you want it to ... not speed up or whatever.

    I have seen the wiper-control unit go bad and cause wipers to come on and off at will something...again, this was in a Ford truck though.

    I'm looking a bit, don't see anything on it. I work with a woman who's husband is a GM vendor, he's at the Arlington plant all the time, I'll ask him when I see him.
  6. udderchaos

    udderchaos Rockstar

    Is the wiper control unit in the column.??? Is it easy to replace..???? It rained on me last night, and the wipers did fine on slow speed. No intermttent wiper action. I just used the "mist" part, when it was barely raining.....
  7. crappieaeg

    crappieaeg New Member

    I had the same thing happen with mine, it is like nemopoppins said, $30.00
    part and they called it a wiper motor modulator. I was having auto start
    put into my 98 Suburban, so just had the dealer do it.

    Hope this helps :? crappieaeg!
  8. 84fiero123

    84fiero123 Epic Member 5+ Years 1000 Posts Platinum Contributor

  9. udderchaos

    udderchaos Rockstar

    I didn't see it on there... But, I saw a couple of other things...does that stuff mean a recall or just what to look for when repairing the stuff listed..???? I SHOULD know this....

    I looked at the service bulletins...
  10. 84fiero123

    84fiero123 Epic Member 5+ Years 1000 Posts Platinum Contributor

    There is a place on there that has just the recalls, unless I am wrong, and I have been known to forget things.
Thread Status:
Not open for further replies.

Share This Page