Just installed new radio now heater will not work

Discussion in 'Chevy C/K Truck Forum' started by baumann6, Nov 10, 2012.

  1. baumann6

    baumann6 New Member

    Just installed new radio in my 2000 k2500 and now the heater will not blow hot air or change off of defrost but the fan works perfect on all settings any ideas what to look for when I tear it all apart tomorrow. Thanks in advance just got the truck on Friday so hoping to get it fixed easy.
     
  2. aloxdaddy99

    aloxdaddy99 Rockstar 3 Years 1000 Posts

    I would start by looking at any hanging wires not terminated. Than look for a loose connection. seems like it will be something easy like that.
     
  3. baumann6

    baumann6 New Member

    I looked for that couldn't see anything loose anyone know how to remove the heater controls so i can get a better look I also just tried the a/c button and circulating button and they also don't light up, this the the style of the controls. Thanks.

    getimage.php.jpg
     
  4. Rhonda36301

    Rhonda36301 New Member

    the controls are held in with with screws if i remember right, Just take your bezal off and u should see them. and the wire just plug on the back
     
  5. RayVoy

    RayVoy Well-Known Member 2 Years 1000 Posts

    I may be late checking in, but it sounds like actuator problems. Did you disconnect the battery while installing the radio?

    Sometimes the HVAC actuators (the electric motors that move air and temp control doors) get out of sync when the battery is reconnected. I have been lucky just disconnecting and reconnecting the battery again. Sometimes the controls need to be moved to different positions and the disconnect retried.
     
  6. baumann6

    baumann6 New Member

    I will go out and try unhooking the battery.

    - - - Updated - - -

    Didn't work by unhooking the battery could I have hooked something up wrong in the new harness for the radio that would have caused problems. I am thinking that something happened when I pushed the radio back in with all the new wires back there at it caused something on the heater controls to not work.
     
  7. Enkeiavalanche

    Enkeiavalanche Rockstar 4 Years ROTM Winner 5000 Posts

    Does that year have Vacume (spelling ) Contrals? look under the dash for diff color hoses? If so check them..
     
  8. baumann6

    baumann6 New Member

    Didn't see any vacuum lines anyone know a good place to order the heater and a/c controls online in Canada just in case the dealer is a very high price.
     
  9. RayVoy

    RayVoy Well-Known Member 2 Years 1000 Posts

    I wouldn't order all that gear before I was sure I needed it.

    If it is dead, you may have blown a fuse, or, as you suggest, you have a wiring problem behind the radio.
     
  10. baumann6

    baumann6 New Member

    I checked fuses and the radio is out and can't see anything wrong.
     

Share This Page

Newest Gallery Photos