Kenwood DNX6990 Issues

Discussion in 'Audio, Video & Gadget Tech' started by aloxdaddy99, Mar 15, 2013.

  1. aloxdaddy99

    aloxdaddy99 Rockstar 4 Years 1000 Posts

    I was driving back to NC from PA and my GPS stopped working 3 times. There was an error message that came up, but of course I couldn't read the entire message as I was driving. I think it said an application error. Has anybody else encountered this issue? How did you resolve this?
  2. Pikey

    Pikey Moderator Staff Member 4 Years ROTM Winner 5000 Posts

    I don't know much about them. But, do you have the latest firmware update? the kenwood website looks like they had an update 1/2012. that may resolve the issue
  3. SurrealOne

    SurrealOne Former Member ROTM Winner 1000 Posts

    Never happened to me. (I loaded latest firmware for my DNX-6960 before installing it in the truck, by the way.)
  4. pmf608

    pmf608 Epic Member 5+ Years 1000 Posts

    I haven't had that problem with my DNX7180 but I've seen it on a few other devices. It is a Windows error since most navigation systems run on Windows CE. The Advent OGM1 in my mom's car does it occasionally. I don' know how to fix it but like others said, I'd suggest making sure you have installed any updates that Kenwood has put out for your unit.
  5. PantheraUncia

    PantheraUncia Rockstar 3 Years 1000 Posts

    I don't have a kenwood nav unit, but my single Din Excelon always gets the latest firmware update :)

Share This Page

Newest Gallery Photos