1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

LH rear tail light issue

Discussion in 'Chevy Silverado Forum (GMC Sierra)' started by TheOnlyWhitey, May 19, 2011.

  1. TheOnlyWhitey

    TheOnlyWhitey New Member

    Hello,

    I have been looking around and haven't found a thread related close enough to my issue so I decided to start a new thread...

    Anyhow, I was driving today and noticed that my LH(driver side) turn signal was blinking really fast. (no prob, burnt out bulb, easy fix.) WELL, not so easy after all. All the lights on my left (and right) side have power to them as they all light up. I tried to troubleshoot myself, tried the following....

    LH side, blinks fast, power to all bulbs. (filament on all bulbs in LH rear do light up slightly.)
    changed bulbs one at a time in the rear, and all of them.
    light do not brighten up when brake is applied
    reverse light does not come on at all when in Reverse
    lights in mirrors on LH all blink in sync with head and tails.
    when emergency lights are used, every turn signal light on truck blink at normal rate.
    all of my RH lights work normal.
    i THINK i check all the fuses related to LH tail lights/reverse lights. (think it was 1 in cab and 2 in engine bay) didnt see a relay although im sure there is one i overlooked....

    ANY ideas or known issues with this problem??? Any help/advice is/will be appreciated greatly.

    2009 silverado 1500 LT 4x4
    no aftermarket electrical accesories installed (only plasti-chrome and stainless:) )
  2. stephan

    stephan Rockstar 3 Years 5000 Posts

    I don't think you have a power or fuse problem on the left side Whitey, or else you wouldn't be showing power to the bulbs however dim they may be.. I think this is a poor ground causing them to be dim & to blink fgast. As for the back up light being out, you don't mention wheteher you checked that bulb fillament or checked for power to it.
  3. TheOnlyWhitey

    TheOnlyWhitey New Member

    Thanks for the reply.
    The reverse light does work. i checked ALL bulbs on the LH side and the filament does slightly light up when head lights are on and when blinker is used. the light TOTALLY goes out when i put truck into reverse.

    As for a ground issue, where should i start looking for the ground and cleaning that up? or since i still have warranty, jus take it in and let them waste their time? lol
  4. GM Customer Service

    GM Customer Service Rockstar 4 Years 500 Posts

    I would recommend contacting your local dealership. They should be able to assist you further. Please feel free to keep me posted regarding the concern.

    Tricia, GM Customer Service.
  5. TheOnlyWhitey

    TheOnlyWhitey New Member

    well, i took it in and told them the problem. got my call less than an hour later. my invoice reads "Found loose connector at rear junction block not seated all the way for lt rear light harness" wow...soo easy :p i am still not exactly sure where this is, i may pull taillight again to see if it is in the back. thanks for looking and advice!
  6. stephan

    stephan Rockstar 3 Years 5000 Posts

    Glad you had warranty Whitey. It's always best to take it to them if you do. I would keep checking it just to make sure it doesn't fail again. There are issues with the boards getting corroded when the seals start leaking & water gets in them.

Share This Page