1. Chevy Truck Forum

    Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online

    Online since 2004, we're the #1 Chevy Truck & SUV user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free

    Registering is Free and Easy! Do it today and we'll see you on the forums soon!

Lights not working on my 2011 after getting back from body shop

Discussion in 'GM Electrical Tech' started by mennor, Jul 28, 2013.

Newest Gallery Photos

  1. mennor

    mennor New Member

    Figured I'd come join this and might find some valuable help on this page. I have a 2011 GMC Sierra 1500 and having an issue. I have an emergency light set up that I usually plugged into Body 3 on the Center Instrument Panel Fuse block. Ive had it like this for over a year with no issues affecting any other part of the truck. Truck went into the shop for about a month for body damage repairs and when I got it back my lights weren't working. Any leads on what could be causing the probelm?
     
  2. donyms

    donyms Rockstar 4 Years ROTM Winner 1000 Posts

    Welcome to the club, it's great to have you aboard. I have no idea what may have happened to your lights but i wanted to welcome you. :glasses:
     
  3. ChevyBoy2009

    ChevyBoy2009 Rockstar 4 Years 500 Posts

    Welcome to GMTC!
     
  4. 4by44ever

    4by44ever New Member

    bad fuse? try to give the lights power directly from the battery(put in a loose fuse)
    if they work it's not the lights,then it's(in orther of checking) a fuse,bad ground,relay,switch,wiring

    good luck!
     
  5. mfleetwood

    mfleetwood Rockstar 4 Years ROTM Winner 5000 Posts

    Welcome to the Club!!

    I moved your thread to the correct section of our Forum and changed your title to match your topic, as this will help in getting you more responses/opinions.
     

Share This Page