long term fuel rate off the charts

Discussion in 'GM Powertrain' started by bobby1964, Jul 15, 2010.

  1. bobby1964

    bobby1964 New Member

    So this morning I i had some issues on start up. Crank an crank than than she firered up.
    I hooked my scanner an no codes than PO 300 was pending I cleared it toke it for a ride.

    Now That code is pending and from what i can see the long term fuel fuel rate
    on both banks are ruining at 25.
    2002 v6 113,000 miles on it.
    I'm still learning about Obed 2. I have all the tools and a 5 volume repair manual on this truck, Id like to figure this out on my on but some times we just need that little bit of
    input to point me in the right direction.

    This is about the 3rd time this has had happed last time i changed the coil wires and plugs.
    Thanks Bob
     
  2. murdog94

    murdog94 Epic Member 5+ Years 5000 Posts

    When was the last time a cap and rotor were done??? Also fuel filter etc?? I have a 97 Blazer with the same motor and have similar faults from time to time.. I have to change the cap about yearly thanks to the MN weather but most people change them around that time. As for P300 i remeber what that code is for, just trying to help.
     
  3. bobby1964

    bobby1964 New Member

    Seems like everything back to normal. Trucks running great.
    Its just a mystery.
     
  4. murdog94

    murdog94 Epic Member 5+ Years 5000 Posts

    I would still take a look at the cap and rotor since there is a chance that it is getting some moisture in it then kicking the code till it drys out then it goes back to normal.
     
  5. bobby1964

    bobby1964 New Member

    So I got around to changing the cap an rotor it was pretty well toast , everything else is new.
    We'll see the next next time it rains. what I just dont get is I can drive in the rain or drive
    thru a car wash and shes fine, Now if its parked all night and it rains that a different story.
     
    Last edited: Jul 28, 2010
  6. murdog94

    murdog94 Epic Member 5+ Years 5000 Posts

    Its from the moisture content in the air. It moved into the Dist easly, and causes arching... Glad to hear you got the new cap and rotor in though.
     

Share This Page

Newest Gallery Photos