1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

looking for some tech support

Discussion in 'Member Introductions' started by robb_03, Jun 5, 2010.

  1. robb_03

    robb_03 New Member

    Has any one taken a TBI 350 out of a late 80's truck and replaced it with a Carb small block? I am having fuel pump issues after putting 300 miles on the truck. The fuel pump runs when you turn the key on but aftger 15-20 seconds it turns off. The electric is shut off to the pump... confused on why it didnt do this right after the swap...
  2. murdog94

    murdog94 Epic Member 5+ Years 5000 Posts

    Sounds like you might have lost your fuel pump relay? And the pump is supposed to shut off when it reaches the proper pressure until it needs more pressure. With out the injectors and computer monitoring everything there might not be signal being sent after it reaches the proper pressure.. Most people who swap these motors to carb, replace the electrical fuel pump with a mechanical or a low pressure fuel pump not mounted in the tank.. When they replace with either they take the pump out and run a pick up tube in place of the pump to keep their guage working.
  3. Eddie Z71

    Eddie Z71 Epic Member 5+ Years 1000 Posts

    Hi, and welcome to the site!:glasses: Glad to have you here! Looks like murdog94 has some great advice! Keep us posted! Good luck!
  4. retired2001

    retired2001 Epic Member 5+ Years 5000 Posts

    Welcome to the GMTruckClub!
  5. robb_03

    robb_03 New Member

    Thanks for the Reply, I stuck with the in tank pump because I have two tanks and with about 6 MPG I want to stick with both tanks. I think I am just going to rewire the system adding a relay that comes from the ignition to my selector switch relay. I shouldnt have any problem that i can forsee. Whats you guys (and girls) advice?

Share This Page