1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

low coolant light comes on and the coolant level is good...

Discussion in 'Chevy Suburban Forum (GMC Yukon XL)' started by kukini808, Apr 25, 2009.

  1. kukini808

    kukini808 New Member

    I know its not the coolant level lol that has been checked and rechecked...any ideas what it could be?
  2. GOTSAND4ME2

    GOTSAND4ME2 New Member

    I had that same nagging problem. Fluid was fine and checked a million times. Come to find out my water pump was leaking on the top of the unit where we could not see the dye that we were putting in to find the leak. Opened the radiator and found it to be almost dry!!! Felt like an idiot. Have that checked out because you could cause some major damage if not taken care of. Put new water pump on and the trouble code cleared itself and I got plenty of coolant. Hope this helps
  3. Jimmiee

    Jimmiee New Member 1000 Posts

    If your radiator is full cold then the sensor may be bad. Try cleaning the plug to the coolant sensor which is located in the recovery tank.
  4. jester

    jester New Member

    bad sensor
  5. vncj96

    vncj96 New Member 1000 Posts

    We have gone through a couple sensors on my mothers vue, you take a corner too sharp and it turns on, but a good tip too check the water pump, otherwise you just have to deal with it, my mom does

Share This Page