1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

Missing 5.3

Discussion in 'General Chevy & GM Tech Questions' started by 99 Z-71, Dec 10, 2008.

  1. 99 Z-71

    99 Z-71 New Member

    Hey guys i'm new here.... I have a 99 Z-71 that is running rough. First of all it is really hard starting. Second it will suddenly start skipping, sputtering, and cutting out. For some odd reason if I put it in neutral and shut it down and restart it, it will straighten out for a moment. It is not throwing any diag codes. I have tuned it up, cleaned my K&N, changed the fuel filter and removed the cats....nothing! Any ideas?:na:
  2. retired2001

    retired2001 Epic Member 5+ Years 5000 Posts

    Welcome to the site. I "assume" you have checked out the fuel filter, since you said you tuned it up. The other thing I might look at is the mass air sensor, since you said you had cleaned the K & N. Did the problem just start suddenly or did it just deteriorate?
  3. 99 Z-71

    99 Z-71 New Member

    YeahI changed the fuel filter also. It started happening suddenly. It worked itself out for about a month and is doing it again it' really weird. Are these computers prone to going bad? How can I check the MAF? Thanks
  4. retired2001

    retired2001 Epic Member 5+ Years 5000 Posts

    On the MAF sensor, the problem I heard of comes from getting oil on the "wires" from cleaning the K & N. You have to be very careful as the wires are delicate. It seems that when "re-oiling" the clean filter a little too much oil goes a long way. Might be worth a try.
  5. ct9a

    ct9a Epic Member 5+ Years 1000 Posts

    Yes MAF sensors are VERY sensitive since they work on frequency. Also, you may want to check/replace cap, rotor, wires and plugs if you didn't do so already.
  6. 99 Z-71

    99 Z-71 New Member

    Well I don't have a cap or rotor but plugs are new and wires are fine.... the truck doesn't do this all of the time.... just when it wants to so I don't think its anything like that. I'll definately check the maf though. Thanks guys!

Share This Page