My 2001 cavelier 4cyl died while going down the road today ,,

Discussion in 'Chevy Compact Cars (Aveo & Cobalt)' started by bsharles, Feb 12, 2012.

Random Gallery Photos

  1. bsharles

    bsharles New Member

    My 2001 cavalier 4cyl died while going down the road today ,,,It acts like it's out of gas but has 1/2 tank in it...car will turn over but doesn't try to start, The trac light oil light and battery light came on just before the car died, Can anyone tell me what else can be wrong ?? is there a relay or something else that could kill the engine or keep it from starting back up.....thank you Bobby
  2. Untouchable

    Untouchable New Member 100 Posts

    It would probably be easier to post in one of the other tech forums, since this one is used for GM Customer Service issues.

    Have you checked to see if the fuel pump is engaging when you turn the key to the on position without starting it? That's the first thing I would do. If you don't hear it engage, then it could be bad or you could have a bad fuel pump relay.
  3. Coach24

    Coach24 New Member 1000 Posts 100 Posts

    water in the fuel?
  4. murdog94

    murdog94 New Member 1000 Posts 100 Posts

    I need to know which 4cyl motor since the 2001 model is when they switched from the iron duke to the eco tech, and there were HUGE problems with the 2001-2002 eco tech 2.2L and the 2.4L really wasnt much better.

    ---------- Post added at 06:10 AM ---------- Previous post was at 06:10 AM ----------

    Also you will want to check the fuel pressure etc.

    ---------- Post added at 06:10 AM ---------- Previous post was at 06:10 AM ----------

    Also you will want to check the fuel pressure etc.

    ---------- Post added at 06:10 AM ---------- Previous post was at 06:10 AM ----------

    Also you will want to check the fuel pressure etc.
  5. bsharles

    bsharles New Member

    Thanks everyone..of course it was just a bad fuel pump....but I thought they checked it first....now it's running again.....bobby
  6. ChevyFan

    ChevyFan Administrator Staff Member 1000 Posts

    Thread moved. This is not a customer service issue, moved to the proper forum. (glad you got it worked out though)

Share This Page