Newest Gallery Photos

  1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

My Tahoe wont start!

Discussion in 'Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)' started by j.alexander9119, Mar 20, 2014.

  1. j.alexander9119

    j.alexander9119 New Member

    I own a 1995 Tahoe 2door, 4x4 and a few years ago I attempted to install an alarm system w/ remote start. The system I bought had been discontinued by the original manufacturer and I couldn't get any tech support from them. I followed the instructions but when I was "finished" with the install and ready to test out the new alarm something wasn't quite right. Once all of the plugs were connected to the brain of the alarm, and the battery reconnected, the alarm started going off and I couldn't get it to disarm or do anything else. I unplugged the ecu for the alarm system and figured I'd try to fix the issue another day. At the time the Tahoe had no issues starting but the alarm system put some sort of a draw on the battery even though it wasn't plugged in. If I let the truck sit for more than a couple of days the battery would be completely dead. Usually there wasn't very many instances where the Tahoe wasn't driven for more than a day at a time. This winter took its toll on the battery and i didn't have the extra money to buy a new one, so I decided to get a used batt. Needless to say I have gotten tired of replacing the battery because I keep deep cycling them till they wont hold a charge. I figured that if I uninstalled the alarm system and put everything back to the way it was I would fix this problem and all would be back to normal. After i unstalled the alarm, and connected the battery up, I tried to start the vehicle and on the first crank the starter tried to trun over the motor for a brief moment and after that there was nothing. I turn the key on and try to start the vehicle and it just clicks. Like the starter is locked up or something. I tried to jump start directly from the starter and couldn't. There was no power going to starter from the battery and I can't figure out why. The battery has a full charge and all wiring has been returned to the factory setup. Any suggestions?

Share This Page