1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

Navigation Install

Discussion in 'Audio, Video & Gadget Tech' started by mrlasenby, Mar 27, 2008.

  1. mrlasenby

    mrlasenby New Member

    I just hooked up a Navigation Unit on my 07 SIlverad (LTZ Package, RSE, Bose Sound you name it I got it). Installation went fine. Had to take to dealer to get system programmed. I now have no OnStar or XM. Any help I could get would greatly be appreciated. Part #on Nav unit is 15940102.

    :glasses: :gasp:
  2. goleee33

    goleee33 New Member

    What brand navigation is it?
  3. mrlasenby

    mrlasenby New Member

    Got it off Ebay. Its is out of a Yukon. I have had it in to 3 dealers to have it reprogrammed and its operational except for no Onstar or Xm. Was told by 1 dealer that this particular radio doesn't come with those features? I am at wits ends as to what to do. There is no manufactur label on it, just a serial and reference #. Per listing on ebay it is a GM model#15940102.
  4. drumrob

    drumrob New Member

    I have a 07 silverado. I bought a pioneer avic 3 navigation and dvd system. I had to purchase a special adapter for the onstar to work. If i remember correctly it was about $60.00. I bought it at circuit city. I did have a little trouble finding it but I think it was becauise the truck was too new so their wasnt any accesories for the silverado yet.
  5. Black LT3

    Black LT3 New Member

    you may have to get a different wire harness in order to made it work i am looking into this right now i will let you know when i have the answer
  6. mrlasenby

    mrlasenby New Member

    Nav Unit

    Well after almost a month, I finally got my Nav Unit working. I can't put my finger on what was wrong. I honestly beleive the 1st unit was programmed wrong by a inexperince technician at the dealership. Received replacement unit went to dealership and a seasoned technician actually allowed me to watch him program it. It was actually a simple process that takes no more than 15 minutes. The ironic thing is there is a GM website that all you have to due is inpute your VIN and select the GM model # and it will tell you which items need to be checked for the proper programming.

    Sorry about the long post but I am excited. I also wired up a LocPic from CoastalTech. It works great. Now my wife can have something to due when we travel. This way I can appreciate my SILVERADO.

    B4 I go I would like to say thanks to all who replied. And a word of advise for all:
    DO YOUR RESEARCH BY DOING ANYTHING? FORUMS ARE A GREAT SOURCE OF INFORMATION.


    :glasses:

Share This Page