need climate control help

Discussion in 'Chevy Silverado Forum (GMC Sierra)' started by bart6180, Jul 8, 2008.

  1. bart6180

    bart6180 Member

    I have an 04 silverado 1500 a few days ago i went to turn the a/c on and it works fine the problem is the vent position switch isn't working--all i have is the defrost position-any where else i set it it just keeps blowing the air on the windshield- what could the problem be?????
    --- the problem seems to have started when i unhooked the battery to put power to the foglights-could this have done something??
     
    Last edited: Jul 8, 2008
  2. curtisjon

    curtisjon New Member

    There are a number of posts on problems with the climate control. Mostly that it blows hot on cold or cold on hot. Mine was blowing hot on one side and cold on the other. Any how the fix was to disconnect the positive terminal to let the computer reset as it seems some logic glitch was causing the problem. So I tried it which corrected my hot/cold issue but then stuck the vent position on defrost like you are talking about. After about hour of being stuck, the system finally starting working properly and has been working great every since. So you might give disconnecting the positive again (which seems to have caused it to start) for about 5 min a try.
     
    Last edited: Dec 2, 2008
  3. ukrkoz

    ukrkoz Rockstar 100 Posts

    as weird as it may sound, curtisjon might be right. it's GM, one never knows. i'd leave it overnight with battery disconnected, there supposed to be some residual codes and "memories" that don't go away for long time in ECM.
     
  4. bart6180

    bart6180 Member

    thanx for the info-the blower started functioning good again about a month and a half ago, but am still having the problem you mentioned of blowing hot on cold and blowing cold on hot, i'll try unhooking the battery and see what happens
     

Share This Page

Newest Gallery Photos