1. Chevy Truck Forum

    Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online

    Online since 2004, we're the #1 Chevy Truck & SUV user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free

    Registering is Free and Easy! Do it today and we'll see you on the forums soon!

Need Help Diagnosing 2000 Suburban 5.3 Tow/Haul light Coming on at Initial startup

Discussion in 'GM Powertrain' started by cmmassi, Nov 27, 2011.

  1. cmmassi

    cmmassi New Member

    I have a 2000 Suburban 1/2 with the 5.3. One day last week when I left to go to work I noticed that the tow/haul light was on after I pulled out of my driveway. At the time I just assumed that I had accidently hit the button.But from that point on every time I start the engine the light comes on and I have to manually turn the OD back on. By default it should be on and have to manually turn it off. I have noticed sometimes that if I put it in reverse first that the light is not on but as soon as I put it in drive it comes on. A while back (maybe a year ago) I noticed that I would have to put the gear shifter towards me while pressing the button to turn the OD off. I assumed that there was a short in the switch or wiring.
    But this is beginning to worry me. a couple of days later it got really warm so on a short trip I turned the ac on but was not able to change the vent position from defrost to vent. No matter what position I would put it on the ac would only blow from the defrost outlet. Even the rear ac will only blow from under the seats. . I have gone thru the fuses but was not able to find any blown. I don't think the two problems are connected, but it seams strange that they both happened. I just don't know if they happened simultaneously.
    My Father-in-law purchased this truck new in 2K. He had to have the transmission rebuilt in 05. I purchased it from my wife's sisters in 06 after he passed. The truck has been meticulously cared for and even though it is showing it's age I want to keep it mechanically sound.Has anyone ever had had this happen to them? Any advise would be appreciated.
     

Share This Page