1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

Need help w/ wifes 04 trailblazer

Discussion in 'General Chevy & GM Tech Questions' started by Hoyt06, Apr 6, 2010.

  1. Hoyt06

    Hoyt06 Member

    O4 trailblazer w/ L6 engine/ LTZ... 1st.problem is her seat heater on the drivers side. The back works but the seat quit working.. the passanger side works fine.. I checked and there doesnt seem to be a fuse for this..?? where do I begin to trouble shoot>???
    2nd. question.. her A/C ..When you push the button ( the snow flake doesnt show up on display, nor does the fan automaticaly turn on, like my 05 silverado) the air seems cool but not as cold as it should.. I have replaced the 2 A/c fuses and that isnt the problem?? Any ideas?? Please guys any help will be appreciated!!! thanks
  2. murdog94

    murdog94 Epic Member 5+ Years 5000 Posts

    On the A/C is the compressor even engaging?? as for the seat heaters i havent dealt with them before.
  3. Hoyt06

    Hoyt06 Member

    No i dont hear the compressor come on???
  4. Hoyt06

    Hoyt06 Member

    when we purchased it the heater didnt work the same way, but we had that repaired.. it was something in the dash by the glove box, but I cant remember what it was called>>>??
  5. Hoyt06

    Hoyt06 Member

    I think it was called a reiostat, or something??
  6. murdog94

    murdog94 Epic Member 5+ Years 5000 Posts

    Well in all reality it could be a ton of things. Low pressure switch, The actual chage in the A/C system. the compressor itself..
  7. jedepsub

    jedepsub Rockstar

    Also check the clutch pulley on the A/C compressor to see if the middle part which is the clutch turns with the pulley, when you have the a/c on!

    On the heated seat, take the switch out & check out the wires & for power. If okay your heater element went bad.
  8. Hoyt06

    Hoyt06 Member

    well I messed around with it for a while.. Actualy I think it is just the "snowflake" display thats not working I can hear the compressor come on and off when I pull the fuse in and out while it is running and the temp control is set at 60 degrees.. And when you shut it off you can hear the compressor releasing some air so it is working, and it blows cold air... As for the seat heater I will have to go to the dealership.. I looked under the seat and I think there is less wiring in the space shuttle!!:gasp:

Share This Page