need help with 4wd problem on 96 tahoe 4door

Discussion in 'General Chevy & GM Tech Questions' started by switchblade94, Jan 29, 2013.

  1. switchblade94

    switchblade94 New Member

    hi i have a 1996 chevy tahoe 4dr 4x4 with the 5.7l push button 4x4 dual vforce exhaust and an aftermarket stereo proffessionally wired, and i put a different set of rims and tires on it (in my heated garage, im from canada) and out of no where the next day i tried to put it into 4wd cause my drive way is icy...and it you could hear a click from the t-case and the 4hi light just flashed and i was like ok so i tried it and i had no power to the front wheels..i kept spinning out in only rwd... so i backed up put the truck in park shut it off turned the power on and tried to put it in 4hi that way and again the t-case made a noise but the 4hi light kept flashing..... i tried it again in neutral and again the t-case made an noise from engaging but the light kept flashing...does anyone know what my problem is...i need it solved asap....as i have a 7 week old son...is it my actuator for my front diff??? i check both fuse boxes and there was a t-case fuse and a 4wd fuse neither of them are blown...
     
  2. vncj96

    vncj96 Epic Member 5+ Years 1000 Posts

    It could also just be the switch itself as that was the case with my suburban
     
  3. switchblade94

    switchblade94 New Member

    i found out its due to my abs wire being broken....on my passenger side front wheel well but now i have a diferent issue... it locked up randomly on me and the emergency brake light came on and the brake peddle sank to the floor and i pulled into my driveway and than its leaking a bit of brake fluid out of my rear drivers side brake drum i check the other three and there not leaking!!!
     

Share This Page

Newest Gallery Photos