1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

Need Mechanic Advice - Electrical Problems

Discussion in 'Audio, Video & Gadget Tech' started by Lindgren, Nov 27, 2008.

  1. Lindgren

    Lindgren New Member

    Hello;

    I am new to this site and joined In hopes that we have a member with some mechanical skills, or ya may have experienced the same problem i am going through.

    My First problem has been an issue for over a year but comes and goes.... What happens is if i dont keep my foot on the gas (which is like manually keeping the rpms up) my Volt meter drops and the car dies. I was sick of having a foot on the gas all the time; even when at a stop just to keep my car on. I ventured under my hood and shook the **** out of my battery, and it seemed to fix the problem from time to time.....
    I realize this could mean my battery terminal could be loose, or do i need a new gas filter or somethin?
    HAS ANYBODY HAD A PROBLEM LIKE THIS?

    My Second problem just happened today. I went to turn the car on, and it sounded like a taser was under my hood (tis tis tis tis) The car wont crank, the stereo and lights all work; but the car wont turn over!?!?!
    ANY IDEAS WOULD BE HELPFUL


    Thanks
    Lindgren
  2. Steban

    Steban New Member

    1. Possible fuel/air restriction. Check your air and fuel filters. and like your say about the battery and voltage dropping, i would check the connections. if you have a bad connection, that means your battery is not getting charged fully and thats could be a problem.

    2. sound like the starter is trying to engangs. if you are sure the starter is working fine, then it sounds like your ring gear on the flywheel or the teath on the starter are chewed up and it wont let it engage to crank the engine. if thats the case you need a new starter or ring gear.

    maybe that is of some help.

Share This Page