1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

new guy here with 0440 trouble

Discussion in 'Member Introductions' started by eddeb11, Apr 18, 2013.

Random Gallery Photos

  1. eddeb11

    eddeb11 New Member

    hey everyone, new guy here. name is Edwin out of Kentucky. I recently purchased a 2002 chevy blazer, 2wd, 4.3 vortec. its a great vehicle it has some good get up and go under the hood and besides the gas mileage im pretty satisfied. lately though as of last week my check engine light came on and hasn't left. I took it to autozone and got back 0440. I researched it online at home and got back a variety of issues which ill admit I honestly am not familiar with. the rubber seal inside the gas cap is intact but is cracked all the way around, going to replace it soon. however the reason im posting this is because early this morning around 3:30ish when I got off work as I was on the highway my check engine light started blinking for a few seconds and then stopped (its still on) I needed gas so I filled up the tank all the way (a whopping $61) and noticed some fluid dripping from underneath the rear driver side by the gas tank. I checked it out and it was water?? confused I drove home and parked it and gave it a closer inspection. there are 2 hoses that are labeled FUEL, and a few others, those are ok it seems. above those hoses it looks like what I can only describe as a rubber nipple like piece that was dripping fluid continuously, so I manned up and tasted, it tasted like dirty water, so good thing its not fuel. Now today when my girl took the truck out she says she can smell fumes heavily in the cab. like I said earlier im not familiar with evap systems or 0440 but I am mechanically apt so im fairly sure with the right information I can save hundreds and do it myself. if anyone on here has had the same symptoms or anything similar or anything related to 0440 please help, any information will be greatly appreciated. thank you.
  2. Pikey

    Pikey Moderator Staff Member 1000 Posts 100 Posts

  3. eddeb11

    eddeb11 New Member

    I checked out that forum post and unfortunately it didn't give me any insightful information on how to fix my issue. I have no idea what these parts are or where to locate them to fix it.
  4. donyms

    donyms Active Member 1000 Posts 100 Posts

    Welcome to the club Edwin, it's great to have you aboard. :glasses:
  5. retired2001

    retired2001 New Member 1000 Posts 100 Posts

    Welcome to the G M T C !
  6. yotchie

    yotchie Member 100 Posts

    welcome to the forum. when i had my 04 Silverado i picked up a Haynes manual. it was the best i could find but it may come in handy

Share This Page