GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER

new guy with 07.5 silverado problems

Discussion in 'Chevy Silverado Forum (GMC Sierra)' started by Aaron Willis, Oct 12, 2011.

  1. Aaron Willis

    Aaron Willis New Member

    Joined:
    Oct 12, 2011
    Messages:
    4
    Likes Received:
    0
    Hello everyone just picked up my first silverado 07 nnbs ext cab 5.3 z71 ltz 57k miles..bought it as a refundable wreck because its mainly what I buy..this may be lengthy but I have some issues. First off I've had the truck back two days now there is a huge exhaust leak , and the truck has no power like its in limp mode. The 4wd will not engage , when you turn the know it goes to 4hi the light stays solid, the switch the know to 4lo in neutral it just blinks..further more there is no indicator light under the p,r,n,d,3 and so on. Speedo Is dead but tach works and no fuel mpg readings ..the tire pressure monitor is working tells you when the door is opened and so on . The stereo,lights,signals,heated seats all work. It does have a check engine light but haven't pulled code yet. All wires seem to be ok..it appears to be missing some fuses but with no owners manual or fuse box lid its hard to see what they are..I got a great deal on the truck so its ok if I spend some money. Thanks in advance for any advice !
    #1
  2. Aaron Willis

    Aaron Willis New Member

    Joined:
    Oct 12, 2011
    Messages:
    4
    Likes Received:
    0
    ok i got some codes today a p0449 (which would never clear) and a v0101 lost comm with tcm..which cleared one time then popped back up..any ideas?
    #2
  3. silveradotrailblazer

    silveradotrailblazer New Member

    Joined:
    Dec 23, 2008
    Messages:
    7,291
    Likes Received:
    20
    Welcome to the club. Good luck with your truck. Sorry I don't do electronics.
    #3
  4. ljmueller

    ljmueller New Member

    Joined:
    Jan 22, 2011
    Messages:
    185
    Likes Received:
    0
    Holy cow! Welcome and good luck to you my friend.
    #4
  5. TRPLXL2

    TRPLXL2 New Member

    Joined:
    Jan 13, 2009
    Messages:
    3,370
    Likes Received:
    8
    Welcome to the club!

    As far as the speedo and fuel gauges, it sounds like the stepper motors are shot. There is a guy who does these gauge cluster repairs on ebay for $179, it is a common problem.
    #5
  6. Aaron Willis

    Aaron Willis New Member

    Joined:
    Oct 12, 2011
    Messages:
    4
    Likes Received:
    0
    Thanks guys ...the stepper motor has come to mind but the tcm code makes me think that's causing it not to shift and Speedo not to work. Any thoughts?
    #6
  7. 99'HEARTBEAT

    99'HEARTBEAT Moderator

    Joined:
    Apr 20, 2009
    Messages:
    3,740
    Likes Received:
    29
    Your 07" Silverado NNBS with the LTZ Trim is a GMT-900 Series which is going to be the 2007" and up Silverado's/Sierra's .......the Problems with the Stepper Motor's are a Common problem as Amy mentioned above.......on the GMT-800 Series.....99" to 07" Trucks/SUV's.
    #7
  8. Aaron Willis

    Aaron Willis New Member

    Joined:
    Oct 12, 2011
    Messages:
    4
    Likes Received:
    0
    *update* put a new tcm on and got it flashed..still no worky..Went through the fuse box for a second time.......TCM BATT fuse blow :great:everything works now as it should. Now to all the other odds and ins. Thanks guys for any input involved!
    #8

Share This Page