1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

New MBRP Exhaust doesn't sound right....

Discussion in 'Chevy Silverado Forum (GMC Sierra)' started by mrbrown88, Apr 18, 2012.

  1. mrbrown88

    mrbrown88 Member

    Hi guys! I recently installed a full MBRP cat back system with the side exit tail pipes. I like the sound of it at idle and when I rev, but when I accelerate hard it makes a loud whushing sound. It is almost like a bad exhaust leak, but I have checked all the clamps and they are all tight. Any ideas on what this could be? Has anyone else with MBRP had this issue?

    Thanks for everyones help in advance, always greatly appreciated!

    Btw, it is a 2011 1500 5.3.
  2. Burden33

    Burden33 Epic Member 5+ Years 500 Posts

    im not really sure what the problem is i got the same exhaust on my truck except its out the rear and i got a loud low tone when acclerating unless im really on the throttle then its more of a raspy sound to it. But my brother got the side exit exhaust and i have never heard that sound come out of his 07.5 but then again we only got 4 speed transmissions. Did you try and contact mbrp them selfs
  3. mrbrown88

    mrbrown88 Member

    I have not tried contacting MBRP yet, but I'm thinking that may be the best solution. Thanks for the help!
  4. Burden33

    Burden33 Epic Member 5+ Years 500 Posts

    No problem tha what we are here for.

Share This Page