1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

New Member here

Discussion in 'Member Introductions' started by Cash1, Jan 17, 2010.

  1. Cash1

    Cash1 New Member

    Hello to all. Need a little assistance. I own a 2004 Silverado 1500 with a 5.3 automatic 2wd. I can not get it to pass emissions due to Code P0133. WHich is O2 sensor left front bank. Replaced it 3 times had computer reset at dealer and several other mechanics excluding myself to look at truck. The only known problem is rough idle after truck is warm and at idle.
    Check engine light will NOT stay off.
    Does anybody out there have any ideas or has experienced the same problem..?
    Help is greatly appreciated, I love my truck

    Thanks,
    Cash1
  2. s5belford

    s5belford New Member 1000 Posts

    sorry I can't be of any help, but welcome to the club!!!
  3. retired2001

    retired2001 New Member 1000 Posts

    Welcome to the site! Hopefully some of the gearheads on the site can give you some relief, but I can't. Good luck!
  4. canislupis69

    canislupis69 New Member 1000 Posts

    Welcome to the site...hopefully someone on here will be able to help out.
  5. Shorty 71

    Shorty 71 New Member 1000 Posts

    Welcome to the club!!
  6. tattooed4life

    tattooed4life New Member

    Welcome to the site!
  7. Eddie Z71

    Eddie Z71 Active Member 1000 Posts

    Hi, and welcome to the site!:glasses:
  8. BLK-Z71

    BLK-Z71 New Member

    Welcome to the club!!

Share This Page