1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

New to the forum not to chevys

Discussion in 'Member Introductions' started by id10t, Dec 29, 2010.

  1. id10t

    id10t New Member

    hey guys long time Chevy guy, just new to forums. i have been kinda an old school guy stuck in the 70's and 80's. quite familiarly with those and everything but just moved into the 90's and bought an old 1992 step-side sierra 1500 z71, and i got a question. the low beams don't work but high beams do. read some place it may be the headlight switch in the dash. what do you think? i did check the bulb and it is good but it is raining and have not had time to put a volt meter on the actual socket yet, hopefully will do that tomorrow to see if i may be just getting low voltage, but let me know what you think about replacing the switch. thanks again for the help and will try to hang out here and help if i can on the older models. lol
  2. stephan

    stephan New Member 1000 Posts

    Welcome to the GM truck club. I also prefer old school rides, so I can't answer your H L que. but somebody will be along that will.
  3. Bigbomber

    Bigbomber New Member 1000 Posts

    Welcome to the club!
  4. murdog94

    murdog94 New Member 1000 Posts

    Welcome aboard!
  5. id10t

    id10t New Member

    Thanks guys,
    Anyone with any ideas about the headlight thing. Low beams not working bulbs are good.
  6. TexasEdition

    TexasEdition New Member

    Glad to have you with us.
  7. retired2001

    retired2001 New Member 1000 Posts

    Welcome to the GMTC !
  8. mfleetwood

    mfleetwood New Member ROTM Winner 1000 Posts

    Hey Jim....Welcome to the Club!! Unfortunately I do not know either, but you may get a better reponse if you post your question in the "tech" area versus "member introductions." I'm not sure all the experts check this thread on a regular basis.
    Last edited: Dec 31, 2010
  9. stephan

    stephan New Member 1000 Posts

    It could be the "dimmer" switch, or wire for low beams disconnected.
    How did you check the low beams to make sure the bulbs were good?
  10. id10t

    id10t New Member

    i just changed the light switch and that wasnt it. didnt change the dimmer though, to check the bulb i pulled it out and checked it with an ohm meter and then hooked up 12v to it with my battery charger and whola it lit up very brightly. now Im wondering if there is a relay and where it is. i wish i had a wiring diagram but being a holiday i didnt get by the local library in time today now they are not open till i have to go back to work monday, dang!!!!!

Share This Page