1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

New with a few questions

Discussion in 'Medium-duty Truck Forum' started by Jasonch, Dec 6, 2011.

  1. Jasonch

    Jasonch New Member

    Hello all,
    I recently purchased two c7500 topkicks, one is a 99, the other a 2000 model. They are both bucket trucks, and we use the 2000 nearly everyday. The reverse lights stay on all the time. That's problem number one. Second problem is the high idle switch doesn't work, it lights up, getting power to switch, but it will not idle up. They are both gas engines, and both came in from northern ill so there is some rust. I tried a search and didn't find anything. Thanks for your help and time.

    Jason
  2. ChevyFan

    ChevyFan Administrator Staff Member 5+ Years 5000 Posts

    Sorry for the delay here, it seems our medium duty moderators have gone on vacation ...
  3. Coach24

    Coach24 Rockstar 3 Years 5000 Posts

    For reverse lights try the connections and see if rust from salt is causing the issue. Also check your back up alarm cause if the lights are staying on so should the back up alarm. I would track the wiring from back to front and look for any corrosion any where. Feel the wire as the corrosion can be hidden within the casings and not visible. We had several problems with power cord failures and found hidden corrosion. Have your mechanic test the wire till he finds a break

Share This Page