Newbie with navigation problems

Discussion in 'Audio, Video & Gadget Tech' started by beerman07, Sep 21, 2010.

  1. beerman07

    beerman07 New Member

    Hello all, my name is Dan and I have a 2008 GMC Sierra. I recently bought a nav unit off ebay which I believe to be a 2010 model because it has the usb. I installed it in my 08 Sierra and got the blue theftlock screen. I took it to the dealer to have it unlocked and he couldn't get it, then I showed him the bulletin where you put in an 06 monte carlo and the unit unlocked. When it restarted it showed the GMC logo on the screen and then showed the clock in the middle of the screen. When we tried to turn it on it wouldn't do anything. I pushed every button on the unit and nothing changed, just showed the time. I did notice the time was an hour fast, not sure if sets the time from satellite or if that was the time from the person I bought it from. Has anyone ran into this problem where it shows the clock but won't turn on? The dealer has no idea what to do now. They tried setting all the options on the radio to what my truck had and still no luck. Suggestions would be appreciated. Thanks.

Share This Page