1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

No Brake Booster Vacuume

Discussion in 'GM Powertrain' started by Demick, Nov 25, 2009.

  1. Demick

    Demick New Member

    So i just finished dropping a 6L motor and a very beefed up 4L60E into my truck. Everything when flawlessly EXCEPT i have no vacuum from the nipple to the Brake Booster. Is there a check valve in it?

    I can pull the airline completely off and the truck still runs awesome. should run like crap because of a massive air leak. Anyone have a idea?

    THANX!

    PS Motor is out of a 2002 Yukon
    Last edited: Nov 25, 2009
  2. Demick

    Demick New Member

    Been reading and if the truck i got the motor from had Hydrolic brakes would that system use no vacuum from the motor? if so how can i remove the nipple to swap it with my old motors one? It spins but is not popping out and since its plastic i dont want to brake it
  3. Demick

    Demick New Member

    thank you for your response. I got a hold of the original owner of the motor. He said it had Hydrolic brakes. and like you said those systems used the PS pump to run. I T'd off the PVC line right off the manifold and that works perfectly.

    But i do have a ABS light on and the e brake light on. So even though the brakes are working fine it could not be getting enough vacuum. How do i check ABS codes? or even clear them. I have a ODBII scanner and a Hypertech unit and both cant clean ABS lites.
  4. Crawdaddy

    Crawdaddy Moderator Staff Member Platinum Contributor 1000 Posts

    The proper term for the hydraulic brakes is hydroboost. I find it odd that you were able to put vacuum on that booster and it works. It should be pressure that drives that brake booster.
  5. Joeairforce

    Joeairforce New Member

    His truck has vacuum booster. Truck his engine came out of had Hydroboost.......
  6. Crawdaddy

    Crawdaddy Moderator Staff Member Platinum Contributor 1000 Posts

    Duh, I knew that... :whistle::lol: Helps when you read the posts right. Good catch Joe!
  7. Joeairforce

    Joeairforce New Member

    :great::glasses:
  8. Demick

    Demick New Member

    checked the wiring on the transmission and xfer case. had some in the wrong places. bam no more lights. there is zero vacuum comming from the hose to the booster. its blocked in hydro boost trucks.

    So I tapped directly off the PVC line at the manifold. works perfect. Enjoying driver her for the first time in a while.

    Thanks for all your help guys :D

Share This Page