no heater fan on remote start

Discussion in 'GM Electrical Tech' started by henrys021500hd, Dec 22, 2013.

  1. henrys021500hd

    henrys021500hd Rockstar

    Yesterday and today I started my 07 2500HD/ diesel and the heater blower did not turn on. I'm sure it always worked in the past. I tried it with the key and the heater fan ran. I sat in the truck and tried the autostart again and it sounded like the fan started then stopped. Any ideas?
    At the same time after I lent the truck to my neighbour to tow their horse trailer out of the field the service trailer brakes came on. When it stops snowing/ raining I will check the fuses. Thanks and Merry Christmas.
     
  2. RayVoy

    RayVoy Well-Known Member 2 Years 1000 Posts

    Mine works the same when the outside temp is cold. I don't know the on/off temps, but when the air is cold the engine water temp needs to reach a certain point before the fan will turn on. Most of the time (when air is cold) I'm in the truck before the fan starts. I have waited for the water temp to get higher and the fan is blowing full blast on defrost. I guess the idea is to move only warm air.
     
  3. henrys021500hd

    henrys021500hd Rockstar

    The fan comes on, but very slow speed, thanks. On my gas cars/ trucks the fan comes on on high. It's funny I never noticed the fan not on, Merry Christmas to all.
     
  4. Glad you figured it out before you started tearing in to anything :)
     
  5. RayVoy

    RayVoy Well-Known Member 2 Years 1000 Posts

    Mine will use high under certain conditions. This morning, the truck was covered with ice (at least 1/2"), I used the remote to start the thaw. It ran for about 10 mins and shut off (this is normal), I restarted it (I was working on the windshield), and the 2nd time, the fan kicked into high right away. It would be interesting to see the program that GM uses.
     

Share This Page

Newest Gallery Photos