no high speed engine rpm??????

Discussion in 'Chevy Suburban Forum (GMC Yukon XL)' started by DoubleDD, Dec 30, 2011.

  1. janikphoto

    janikphoto Rockstar 3 Years 100 Posts

    Yeah, I read a nice long thread on some fishing boat forum, and the guys all said to change the fuel return regulator, if I remember correctly. A bunch of good info on the suburban, since so many guys use it to haul big boats, I guess... They talked about a bad injector design that allows excessive carbon build-up.
     
  2. dipstick

    dipstick Member 2 Years 100 Posts

    If yours is tbi.. you only have two injectors.

    ---------- Post added at 05:55 PM ---------- Previous post was at 05:49 PM ----------

    What i would do first ..clean the maf sensor . Can get maf cleaner at auto parts.
    Take off spray good .. let dry put back. Make sure all down stream of maf is tight and air filter is clean Do not touch filaments on maf... and dis connect battery first.
    Lets get the maf and fuel filter out of the equation.. go from there.
    Are you getting a service light?
     
  3. Ape

    Ape Member 100 Posts

    Ya, sorry.....Didn't mean to imply I have more than 2.

    By the way.....I just had a new gremlin pop it's head up on my 89 burb this morning. It started just fine, but when I went to turn on the heater it shut everything down. :-( It did this 2 times and then I had no power to anything after that. So now I'm trying to figure out what would be shorting the entire thing out. :-/
     
  4. DoubleDD

    DoubleDD New Member

    Changed the fuel filter and now she's just like new! Full of gitty up and Go!
     

Share This Page

Newest Gallery Photos