1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

NO POWER!! Bogs down!

Discussion in 'Performance & Fuel' started by Avatar, Jan 8, 2010.

  1. Avatar

    Avatar New Member

    Good morning! I have a 1992 1500, 4x4 with the 5.0 in it. It has TBI and the problem I have with it is that when I try to accelerate quickly it just bogs down, no power. I can get up to hwy speeds as long as I massage the gas pedal. Any help? Thanks!!
    Craig
  2. bigburb

    bigburb New Member 100 Posts

    How long has it been since you changed your fuel filter? Have you ever done a tune-up? Your fule filter could be clogged, or your plugs could be gettin' old. There's a lot of other things that could be wrong, these are just the first two things that come to mind.
  3. 95Chevyk1500

    95Chevyk1500 New Member 100 Posts

    mine did that and i changed the coolant temp sensor. it was running really rich. black smoke when i started it up, just really crappy. replaced that sensor, problem solved!
  4. Avatar

    Avatar New Member

    Got it!

    Thanks bigburb! Changed out the fuel filter and now have full power back! Nice, easy, cheap fix!
  5. lmin2

    lmin2 New Member

    Hey suburban owners. I love this site. I have made a lot of fix's and upgrades with your help but I have one issue that I cannot put my finger on. My 2000 suburban hesitates and shifts into overdrive when going uphill and on normal grade takes a while get get up speed even when I press the pedal to the floor..I have checked fuel pressure-ok,changed fuel filter, cleaned throttle body, cleaned maf, cleaned tps(throttle possition sensor) added a cai,changed spark plugs and wires and changes transmission fluid...any other suggessions...help!!!!!!! Thanks.
  6. Stealth

    Stealth New Member 1000 Posts 100 Posts

    Does this happen in tow/haul mode too, or just in normal, unloaded driving?

Share This Page