1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

No power locks?

Discussion in 'Chevy C/K Truck Forum' started by Rbernsdo, Mar 23, 2012.

  1. Rbernsdo

    Rbernsdo Rockstar

    Hey all, quick question about some door locks. I have a 1996 Chevy 1500 ext cab short box 5.7 yada yada yada. My power locks have not worked since i got my truck, when I tried the power lock keyless entry i remember that sometimes it would move the locks a little bit but not enough to close/open them. The juice it seemed to have had finally dissapeared. SO as of right now, my locks will not lock or unlock with either the button on my keyless entry deal or the button inside my truck. First question, I was told that the actuators would most likely not go out at the same time and people have told me my wiring is F*(&ed. I have traced the line best as i could, I see no stripped or wrecked wires. When I hit the button on the door panel, I can hear the locking system, it just doesnt move the locks at all. So, for one, any ideas on that one? Secondly, if it does end up being the actuators, are they pretty universal? I am not a huge scrapper/dig through a junk pile and make something work kinda guy, well most of the time, but my brother destroyed his 99 monte carlo and its sitting back at the house. Would that be something I could use if it was the initial problem? I have tried replacing the actual switch part, the plastic deal that is on the door railing, it does the same thing. Any help would be greatly appreciated. Thanks!
  2. moogvo

    moogvo Epic Member 5+ Years 1000 Posts

    It is unlikely the actuators. What you need to do is take off a door panel and check the voltage to the actuators. The panels are not hard to take off. Pop off the triangle on the inside where the mirror is. Then take the 2 phillips head screws out of the arm rest. Gently pry the window/lock panel out of the door panel by lifting up along the inside edge starting from back to front. Once it lets go, lift the rear end of the lock panel and slide rearward as there is a small plastic tang on the front edge that slips under the lip of the hole.

    Then, gently pry the plastic panel away from the metal inner door with a large screw driver or upholstery removal tool. Be careful not to break the plastic clips that hold the panel on. Once you are at the top of the panel, push up on the panel to release it from the window opening.

    The actuator is at the rear edge of the door. It is riveted to the inner door. Disconnect the weatherpak connector from the actuator and probe the voltage inside. If you re getting less than 12 volts when the lock button is pressed, then it is either the module or the voltage feeding the module. If the voltage is 12V at the connector, then it is likely your actuators at that point.

    If you have low voltage at the actuators, you will have to do some detective work. you will need to find the module and check the voltage on the connector into the module. If it is low at the input, then you have a wiring problem upstream that you get to track down. If input voltage is normal, then check the voltage from the output of the module. If it is low, then you need to replace it. If it is normal, then you have a wiring issue between the module and the power lock button. The wiring goes first to the driver's side and then leaves there and goes to the passenger's side. You will probably have to have the driver's side buttons plugged in in order for the passenger's side switches to work.

    Good luck on this and let us know how you make out!

    Tom
    Last edited: Mar 23, 2012
  3. Dana W

    Dana W Member 2 Years 100 Posts

    OR, you could have a moving parts corrosion issue like I do. My my 99 burb pass side rear door is frozen in the unlocked position. I can't even push the lock thumb button down with my hand.
  4. Rbernsdo

    Rbernsdo Rockstar

    After installing a inside door handle on the passenger side a while back, the lock would also not push down, yesterday i took the linkage off of the actuator so it is free, it now can unlock and lock manually. When I hit the button, I can here the electronic relay, something is just holding it back. I hit the lock unlock and look touch and feel the actuator and there is nothing coming from it. Still not sure, no one seems to have had an idea really, I still don't believe its a wiring/ wire situation being that it relays and I can here it. Still Lost but thanks for the input.
  5. DAD HELP

    DAD HELP New Member

    Did you check for power at acuator as previously mentioned, if you have proper power and ground at actuator, which alternate with lock and unlock position then that leaves a bad actuator. Follow MOOGVO suggested electrical troubleshooting if no power at actuator.

Share This Page