1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

no power to push button 4wd

Discussion in 'GM Powertrain' started by dcjones13, Dec 24, 2008.

  1. dcjones13

    dcjones13 New Member

    i have a 2006 silverado vortec max. while driving all power to 4wd push buttons would go away. stop annd turn truck off and turn back on. power would come back on. now have no power. checked all plugs and fuses to be ok. any and all response will be helpfull. thank you and merry christmas...
  2. Springthing

    Springthing New Member 1000 Posts 100 Posts

    My first instinct will always be the push button unit itself. I would invest in a salvage yard switch module to diagnose the problem. At least you'll know if it's the module or something else. I just replaced mine and the replacement was $10.

    Good luck
  3. JMoney02

    JMoney02 New Member 100 Posts

    Springthing is right, switches for these are some what crude and usually go bad first, same for the power locks and windows. replace these first to eliminate them and use the salvage yard as they are a dime to a dozen and quite a few models will fit your and a lot cheaper also.....

    Jeff
  4. dcjones13

    dcjones13 New Member

    i tried the pulling of fuse and reinstalling and disconnecting battery(read another forum). tried another transfer case dash switch. still do not have electricy to switch. did not fix problem. does anyone have anyother ideas. thanks....
    Last edited: Jan 8, 2009
  5. Springthing

    Springthing New Member 1000 Posts 100 Posts

    Does it still go into 4WD when you push the buttons (only the lights that are not working) or does the control module not work at all - no lights, doesn't go into 4wd?
  6. dcjones13

    dcjones13 New Member

    does not go into 4wd (no clicks or anyother sounds) and no lights or power. do have lights when i turn key on but goes right off when everything comes on, ie: gauges, stereo, etc...
  7. vncj96

    vncj96 New Member 1000 Posts 100 Posts

    try and look under the dash and follow the wires from the control module and see if they are rubbing on something to wear at the wire insulation and the switch has grounded out
  8. JMoney02

    JMoney02 New Member 100 Posts

    I believe that there is also a small set(wires) that go to the transfer case for the signal to switch, check that also, you have power loss from the key to the switch function...

    Jeff
    Last edited: Jan 9, 2009
  9. dcjones13

    dcjones13 New Member

    checked all wiring and plug connections to be ok. any other ideas? thanx....
    also have power to fuse and switch, just no lights or action(when buttons pushed).
    Last edited: Jan 9, 2009
  10. JMoney02

    JMoney02 New Member 100 Posts

    Where is the bulb in this switch and where is the ground wire go to from back of the panel? It should connect to other set of light displays for something else? Is other light features not functioning as well?
    Still sounds as though you have no power going to that perticular switch. Check 4wd relays, it does have them I believe????

    Jeff

Share This Page