Non-Bose factory stereo

Discussion in 'Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)' started by Madcat81, May 18, 2017.

  1. Madcat81

    Madcat81 New Member

    I just purchased a 2001 Tahoe. It has factory Subwoofer & amplifier. My 2nd row door speakers are not functioning. I've been told that it could be a damaged channel on the amplifier. I want to know with the 4 channel receiver how the signal is getting to the 6 speakers. 2 front doors, 2 rear doors & 2 in the rear pillars. Thanks for any information.
     
  2. RayVoy

    RayVoy Epic Member 5+ Years 5000 Posts

    Don't over think it, door speakers get wet and stop working.

    You need to remove door panel and test the speaker(s).
     
    Beachbourbon likes this.
  3. Beachbourbon

    Beachbourbon Active Member 100 Posts

    RayVoy is right...those speakers are notorious for disintegrating. check them first and it is likely you will visually see they need to be replaced.
     
    RayVoy likes this.
  4. Madcat81

    Madcat81 New Member

    I've already pulled off the speakers, they appear fine. I checked the wires and there is no signal going through the wires. That is why I believe that the channel on the amplifier isn't working to the door speakers. Can anyone tell me if the rear pillars are on their own channel? Or do the rear door & pillar speakers work on the same channel?
     
  5. RayVoy

    RayVoy Epic Member 5+ Years 5000 Posts

    I suspect only two channels and front and rear split with fade.

    The doors will have the low and mid-range, the pillars would have the highs...........one output, frequency split.
     

Share This Page

Newest Gallery Photos