1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

np246 transfer case problem? Or something else

Discussion in 'GM Powertrain' started by smcdo9nnell1, Jul 21, 2011.

  1. smcdo9nnell1

    smcdo9nnell1 New Member

    Hi Everyone, I am new to your forum and I am having a heck of a time with my wifes 2001 yukon xl 4x4. I can fix it if I can diagnose the problem. These are the symptoms I am having. The light for the gear selector on the display only lights up behind D,R,1,2 but not neutral or park. It lights up behind P for a sec when I first start the car then it goes off. I cannot get the transfer case to go into neutral, maybe because it isnt recognizing the trans. is in neutral? My front drive shaft turns when the car is in 2wd and I feel a vibration coming from the driveshaft under my feet when moving. I have replaced nsbu switch already thinking it would fix the display problem but it didnt. I have checked the tc motor and it if functional and I have removed the front drive shaft, U joints are good. The vibration went away after removing the drive shaft. I have searched for hours trying to find out if the front driveshaft should turn freely in 2wd but I cant find anything telling me for sure. One thing that is very strange is that the driveshaft can be turned with a pair of channel locks when in 2wd. It is almost as if the clutches are lightly engaged. Oh I also took the tc motor off and worked the selector by hand and it still didnt free up any better.
    Can someone tell me what im looking at here, this thing is outside my realm of knowledge.
    Thanks for your time and help with this problem.
    Sean
  2. silveradotrailblazer

    silveradotrailblazer Epic Member 5+ Years ROTM Winner 5000 Posts

    Welcome to the club. Have you ever changed the transfer case fluid? It should be changed every 40,000 miles. It takes Auto-Trac ll fluid and you can only get it from a GM dealer. Its blue in color. Have you checked the t/c fluid level?
  3. smcdo9nnell1

    smcdo9nnell1 New Member

    The fluid is almost new, I changed it a month or so ago. It still looks great, and I did use the gm recommended blue tc oil. I cant figure this one out. I installed the pump rub update kit a year ago and it has been great until the last few weeks. Very strange.

Share This Page