1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

OBDII Scan Tool Not working

Discussion in 'Chevy Suburban Forum (GMC Yukon XL)' started by i_build, Apr 14, 2009.

  1. i_build

    i_build Rockstar

    I am trying to use my scantool http://www.obd2allinone.com/sc/details.asp?item=obd2usb to read my 99 Suburban LT and I keep getting an error reading. I have tried numerous freeware software and all have a problem reading. I can take the setup to my 97 Maxima and it reads just fine. I see that it's OBDII any idea why I cant read it?
    Last edited: Apr 14, 2009
  2. TRPLXL2

    TRPLXL2 Epic Member 5+ Years 1000 Posts Platinum Contributor

    I have a pretty good idea what your problem is, you tipped me off by saying that it worked on your foreign car and not your GM. There is such a thing as a generic OBD II which will scan most 1996 and newer imports such as Ferrari, Bentley, BMW, Mercedes, Aston Martin, and such. Then there is what is called the GM specific OBD II which will scan 1996 and newer GM, Cadillac, Buick, Oldsmobile and so on. That is the only thing I can think of right now, hopefully some one else will be able to pitch in too.:great:
  3. MrShorty

    MrShorty Epic Member Staff Member 5+ Years 1000 Posts

    Can you be more specific as to the error. It seems the most common error I see mentioned is a "no power" or "can't communicate with vehicle" kind of error. A large majority of the time, the vehicle power supply to the OBD2 connector has failed. And, quite often, that is a blown fuse (cigarette light fuse, I believe). Anyway, my first suggestion would be to check for power to the connector.
  4. Dr_Zero

    Dr_Zero Epic Member 5+ Years 500 Posts

    Take a ride up to Autozone or Advance and see if they can scan it for you that way you can eliminate the scanner or the plug.

    If you need a new scanner check out this line

    http://www.auteltech.com/ms409.htm

     Works on all 1996 and later OBDII compliant US, European and Asian vehicles

    ● Retrieves generic (P0, P2, P3, and U0) and manufacturer specific (P1, P3, and U1) codes
    ● Supports CAN (Controller Area Network) and all other current
      OBD-II protocols
    ● Built-in OBD-II DTC lookup library


    Runs about $80
  5. JoeMagraine

    JoeMagraine New Member

    It could be that the speed of your device is too fast for the truck's computer.

    You have to slow it down with a small script with a program like Hypertherminal.


    You can check this blog :

    http://www.carplugs.com/blog
  6. i_build

    i_build Rockstar

    I am getting power from thr port because my reader has a light and I have been getting errors that say it cant communicate and 1 software package said the data returned was invalid. The reader has transmit and recieve lights and both blink so I'm assuming data is going back and fourth. My best bet as mentioned it to bring it to the auto parts store and have them try to read it. Will post back results after.
  7. unplugged

    unplugged Epic Member 5+ Years 1000 Posts

    I tried using my scanner on a friends Ford truck and it wouldn't read it because it was the CAN protocol OBDII. Don't know if you scanner is CAN compliant or even if your vehicle is using CAN. Next time I upgrade scanners I'll definitely be looking for CAN capability.

Share This Page